summaryrefslogtreecommitdiffstats
path: root/package/webkit
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-12-22 09:04:25 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-22 23:46:38 +0100
commite4cce3732ce024cd0b7139ac3aeeaca9da6c7e0e (patch)
tree4d8b63051dadece3d76fe796847b50e21c3c80df /package/webkit
parent84241e949901b2e014c92ad55303de7796820bc2 (diff)
downloadbuildroot-novena-e4cce3732ce024cd0b7139ac3aeeaca9da6c7e0e.tar.gz
buildroot-novena-e4cce3732ce024cd0b7139ac3aeeaca9da6c7e0e.zip
webkit: bump to version 1.2.5
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/webkit')
-rw-r--r--package/webkit/webkit-fix-build-issue-with-old-gtk.patch (renamed from package/webkit/webkit-1.2.3-fix-build-issue-with-old-gtk.patch)0
-rw-r--r--package/webkit/webkit-fix-compilation-on-DirectFB.patch (renamed from package/webkit/webkit-1.2.3-fix-compilation-on-DirectFB.patch)0
-rw-r--r--package/webkit/webkit-fix-pool.patch67
-rw-r--r--package/webkit/webkit-pthread_getattr_np.patch (renamed from package/webkit/webkit-1.2.3-pthread_getattr_np.patch)0
-rw-r--r--package/webkit/webkit.mk10
5 files changed, 70 insertions, 7 deletions
diff --git a/package/webkit/webkit-1.2.3-fix-build-issue-with-old-gtk.patch b/package/webkit/webkit-fix-build-issue-with-old-gtk.patch
index 2b20bae6d..2b20bae6d 100644
--- a/package/webkit/webkit-1.2.3-fix-build-issue-with-old-gtk.patch
+++ b/package/webkit/webkit-fix-build-issue-with-old-gtk.patch
diff --git a/package/webkit/webkit-1.2.3-fix-compilation-on-DirectFB.patch b/package/webkit/webkit-fix-compilation-on-DirectFB.patch
index 256f8a170..256f8a170 100644
--- a/package/webkit/webkit-1.2.3-fix-compilation-on-DirectFB.patch
+++ b/package/webkit/webkit-fix-compilation-on-DirectFB.patch
diff --git a/package/webkit/webkit-fix-pool.patch b/package/webkit/webkit-fix-pool.patch
new file mode 100644
index 000000000..5a66a8229
--- /dev/null
+++ b/package/webkit/webkit-fix-pool.patch
@@ -0,0 +1,67 @@
+Description: Fixup pool and add sparc support
+Nixed from gentoo
+
+--- webkit-1.2.1.orig/JavaScriptCore/wtf/ListHashSet.h
++++ webkit-1.2.1/JavaScriptCore/wtf/ListHashSet.h
+@@ -127,7 +127,7 @@ namespace WTF {
+ : m_freeList(pool())
+ , m_isDoneWithInitialFreeList(false)
+ {
+- memset(m_pool.pool, 0, sizeof(m_pool.pool));
++ memset(m_pool, 0, sizeof(m_pool));
+ }
+
+ Node* allocate()
+@@ -171,7 +171,7 @@ namespace WTF {
+ }
+
+ private:
+- Node* pool() { return reinterpret_cast<Node*>(m_pool.pool); }
++ Node* pool() { return reinterpret_cast<Node*>(m_pool); }
+ Node* pastPool() { return pool() + m_poolSize; }
+
+ bool inPool(Node* node)
+@@ -182,10 +182,7 @@ namespace WTF {
+ Node* m_freeList;
+ bool m_isDoneWithInitialFreeList;
+ static const size_t m_poolSize = 256;
+- union {
+- char pool[sizeof(Node) * m_poolSize];
+- double forAlignment;
+- } m_pool;
++ uint32_t m_pool[(sizeof(Node) * m_poolSize + sizeof(uint32_t) - 1) / sizeof(uint32_t)];
+ };
+
+ template<typename ValueArg> struct ListHashSetNode {
+--- webkit-1.2.1.orig/WebCore/platform/text/AtomicString.cpp
++++ webkit-1.2.1/WebCore/platform/text/AtomicString.cpp
+@@ -103,9 +103,9 @@ static inline bool equal(StringImpl* str
+ if (string->length() != length)
+ return false;
+
++#if CPU(ARM) || CPU(SPARC) || CPU(SH4)
+ // FIXME: perhaps we should have a more abstract macro that indicates when
+ // going 4 bytes at a time is unsafe
+-#if CPU(ARM) || CPU(SH4)
+ const UChar* stringCharacters = string->characters();
+ for (unsigned i = 0; i != length; ++i) {
+ if (*stringCharacters++ != *characters++)
+--- webkit-1.2.1.orig/WebCore/platform/text/StringHash.h
++++ webkit-1.2.1/WebCore/platform/text/StringHash.h
+@@ -54,13 +54,13 @@ namespace WebCore {
+
+ // FIXME: perhaps we should have a more abstract macro that indicates when
+ // going 4 bytes at a time is unsafe
+-#if CPU(ARM) || CPU(SH4)
++#if CPU(ARM) || CPU(SPARC) || CPU(SH4)
+ const UChar* aChars = a->characters();
+ const UChar* bChars = b->characters();
+- for (unsigned i = 0; i != aLength; ++i) {
++ for (unsigned i = 0; i != aLength; ++i)
+ if (*aChars++ != *bChars++)
+ return false;
+- }
++
+ return true;
+ #else
+ /* Do it 4-bytes-at-a-time on architectures where it's safe */
diff --git a/package/webkit/webkit-1.2.3-pthread_getattr_np.patch b/package/webkit/webkit-pthread_getattr_np.patch
index b71c8789e..b71c8789e 100644
--- a/package/webkit/webkit-1.2.3-pthread_getattr_np.patch
+++ b/package/webkit/webkit-pthread_getattr_np.patch
diff --git a/package/webkit/webkit.mk b/package/webkit/webkit.mk
index 3f4e8fe24..7a5429ca2 100644
--- a/package/webkit/webkit.mk
+++ b/package/webkit/webkit.mk
@@ -3,16 +3,12 @@
# webkit
#
#############################################################
-WEBKIT_VERSION = 1.2.3
-WEBKIT_SOURCE = webkit-$(WEBKIT_VERSION).tar.gz
-WEBKIT_SITE = http://www.webkitgtk.org
+WEBKIT_VERSION = 1.2.5
+WEBKIT_SITE = http://www.webkitgtk.org
WEBKIT_INSTALL_STAGING = YES
-WEBKIT_LIBTOOL_PATCH = NO
-
-WEBKIT_DEPENDENCIES = host-flex host-gperf icu libcurl libxml2 libxslt \
+WEBKIT_DEPENDENCIES = host-flex host-gperf icu libcurl libxml2 libxslt \
libgtk2 sqlite enchant libsoup jpeg libgail
-
WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config
ifeq ($(BR2_PACKAGE_XORG7),y)