summaryrefslogtreecommitdiffstats
path: root/package/vtun/vtun-002-fix-ssl-headers-checks.patch
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-02-17 13:22:31 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-22 23:44:11 +0100
commit2b36d80c63afae74bf759f27e3eecf9e1f394e77 (patch)
tree1b282846aadc0e41510f6fbd35dbf466ef4d3a2c /package/vtun/vtun-002-fix-ssl-headers-checks.patch
parent54b2bad158fd10c0514fe37832108c30e0c4a291 (diff)
downloadbuildroot-novena-2b36d80c63afae74bf759f27e3eecf9e1f394e77.tar.gz
buildroot-novena-2b36d80c63afae74bf759f27e3eecf9e1f394e77.zip
package/vtun: update to 3.0.3
Against all odds, vtun had a new release sometime last year. Still, the code needs patching: - the existing patch to fix installation has been refreshed - the existing patch to fix blowfish header location has been replaced (see below) - configure looks in hard-coded, host paths (eg. /usr/include) without any consideration for scross-compilation --> new patch - configure.in does not even pass an autoreconf without a bit of love first (it's written in an ancient dialect that autoreconf does no longer recognise) --> new patch Remove obsolete, unused, bit-rotting scripts and warning. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/vtun/vtun-002-fix-ssl-headers-checks.patch')
-rw-r--r--package/vtun/vtun-002-fix-ssl-headers-checks.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/vtun/vtun-002-fix-ssl-headers-checks.patch b/package/vtun/vtun-002-fix-ssl-headers-checks.patch
new file mode 100644
index 000000000..765411af8
--- /dev/null
+++ b/package/vtun/vtun-002-fix-ssl-headers-checks.patch
@@ -0,0 +1,47 @@
+configure.in: do not hard-code search patch for SSL headers
+
+Do. Not. Do. That. It breaks cross-compilation.
+
+Also use the SSL headers dir to look for blowfish headers.
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+diff -durN vtun-3.0.3.orig/configure.in vtun-3.0.3/configure.in
+--- vtun-3.0.3.orig/configure.in 2009-03-29 12:08:51.000000000 +0200
++++ vtun-3.0.3/configure.in 2013-02-16 23:44:44.004339680 +0100
+@@ -166,7 +166,7 @@
+ AC_MSG_RESULT()
+ AC_CHECKING( for md5 Library and Header files ... )
+ AC_SEARCH_HEADERS(md5.h,
+- $SSL_HDR_DIR /usr/include/openssl "" /usr/include /usr/include/ssl /usr/local/include /usr/local/ssl/include /usr/include/sys,
++ $SSL_HDR_DIR "" ,
+ ,
+ AC_MSG_ERROR( SSL headers not found. )
+ )
+@@ -176,7 +176,7 @@
+ AC_MSG_RESULT()
+ AC_CHECKING( for blowfish Library and Header files ... )
+ AC_SEARCH_HEADERS(blowfish.h,
+- $BLOWFISH_HDR_DIR /usr/include/ssl /usr/include/openssl /usr/include /usr/local/include /usr/local/ssl/include /usr/include/crypto,
++ $BLOWFISH_HDR_DIR $SSL_HDR_DIR,
+ AC_CHECK_LIB(crypto, BF_set_key,
+ [
+ LIBS="$LIBS -lcrypto"
+@@ -193,7 +193,7 @@
+ AC_MSG_RESULT()
+ AC_CHECKING( for AES Library and Header files ... )
+ AC_SEARCH_HEADERS(aes.h,
+- $SSL_HDR_DIR /usr/include/ssl /usr/include/openssl /usr/include /usr/local/include /usr/local/ssl/include /usr/include/crypto,
++ $SSL_HDR_DIR ,
+ AC_CHECK_LIB(crypto, AES_set_encrypt_key,
+ [
+ AC_DEFINE(HAVE_SSL_AES)
+@@ -208,7 +208,7 @@
+ AC_MSG_RESULT()
+ AC_CHECKING( for EVP Library and Header files ... )
+ AC_SEARCH_HEADERS(evp.h,
+- $SSL_HDR_DIR /usr/include/ssl /usr/include/openssl /usr/include /usr/local/include /usr/local/ssl/include /usr/include/crypto,
++ $SSL_HDR_DIR ,
+ AC_CHECK_LIB(crypto, EVP_EncryptInit,
+ [
+ AC_DEFINE(HAVE_SSL_EVP)