summaryrefslogtreecommitdiffstats
path: root/package/vsftpd
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-22 19:47:41 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-22 19:47:41 +0000
commit8bba7f0d67d686836258d7ee48bd7fe582efa4e1 (patch)
tree21d0d05a398bf7964f196920f4bf07362a2e0e04 /package/vsftpd
parentbca6a68ab405cb10b11818b9f9984e262169e5af (diff)
downloadbuildroot-novena-8bba7f0d67d686836258d7ee48bd7fe582efa4e1.tar.gz
buildroot-novena-8bba7f0d67d686836258d7ee48bd7fe582efa4e1.zip
vsftp: enable and fix linking
Patch by Wade Berrier. It still errors out on sysdeputil.c for me, but this is no worse than it was before, so committing.
Diffstat (limited to 'package/vsftpd')
-rw-r--r--package/vsftpd/vsftpd.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/vsftpd/vsftpd.mk b/package/vsftpd/vsftpd.mk
index d9dbd195c..ad23192e6 100644
--- a/package/vsftpd/vsftpd.mk
+++ b/package/vsftpd/vsftpd.mk
@@ -9,9 +9,13 @@ VSFTPD_SITE:=ftp://vsftpd.beasts.org/users/cevans
VSFTPD_DIR:=$(BUILD_DIR)/vsftpd-$(VSFTPD_VERSION)
VSFTPD_CAT:=$(ZCAT)
VSFTPD_BINARY:=vsftpd
+VSFTPD_TARGET_BINARY:=usr/sbin/vsftpd
ifeq ($(BR2_PACKAGE_OPENSSL),y)
VSFTPF_PREREQ:=openssl
+VSFTPD_LIBS:=-lcrypt -lssl
+else
+VSFTPD_LIBS:=-lcrypt
endif
ifeq ($(BR2_LARGEFILE),)
#BR2_VSFTPD_CFLAGS:=-U_LARGEFILE64_SOURCE -U_FILE_OFFSET_BITS
@@ -45,7 +49,7 @@ endif
$(VSFTPD_DIR)/$(VSFTPD_BINARY): $(VSFTPF_PREREQ) $(VSFTPD_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) $(BR2_VSFTPD_CFLAGS)" -C $(VSFTPD_DIR)
+ $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) $(BR2_VSFTPD_CFLAGS)" LIBS="$(VSFTPD_LIBS)" -C $(VSFTPD_DIR)
$(TARGET_DIR)/usr/sbin/$(VSFTPD_BINARY): $(VSFTPD_DIR)/$(VSFTPD_BINARY)
cp -dpf $< $@