summaryrefslogtreecommitdiffstats
path: root/package/ux500-firmware
diff options
context:
space:
mode:
authorGregory Hermant <gregory.hermant@calao-systems.com>2012-11-30 02:39:12 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 07:59:16 -0800
commit367096b0e33913f47545ef8702eaa609960baa1f (patch)
tree0681083f03bff029b4a172a3cde367f3c3b390f7 /package/ux500-firmware
parent7e9f8ad164e4776ff89e0f7d674e77032a472d54 (diff)
downloadbuildroot-novena-367096b0e33913f47545ef8702eaa609960baa1f.tar.gz
buildroot-novena-367096b0e33913f47545ef8702eaa609960baa1f.zip
ux500-firmware: new package
Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> (with the calao_snowball_defconfig) Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ux500-firmware')
-rw-r--r--package/ux500-firmware/Config.in7
-rw-r--r--package/ux500-firmware/ux500-firmware.mk22
2 files changed, 29 insertions, 0 deletions
diff --git a/package/ux500-firmware/Config.in b/package/ux500-firmware/Config.in
new file mode 100644
index 000000000..7e8a94b2a
--- /dev/null
+++ b/package/ux500-firmware/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_UX500_FIRMWARE
+ bool "ux500-firmware"
+ help
+ This package provides various binary firmware files (closed binary blobs)
+ for the Azurewave AW-NH580 combo module (wifi, bt, gps).
+
+ https://launchpad.net/~igloocommunity-maintainers/+archive/snowball/+files/
diff --git a/package/ux500-firmware/ux500-firmware.mk b/package/ux500-firmware/ux500-firmware.mk
new file mode 100644
index 000000000..d354468ab
--- /dev/null
+++ b/package/ux500-firmware/ux500-firmware.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# ux500-firmware
+#
+#############################################################
+UX500_FIRMWARE_VERSION = 1.1.3-6
+UX500_FIRMWARE_SOURCE = ux500-firmware_$(UX500_FIRMWARE_VERSION)linaro1.tar.gz
+UX500_FIRMWARE_SITE = https://launchpad.net/~igloocommunity-maintainers/+archive/snowball/+files/
+UX500_FIRMWARE_LICENSE = Snowball click-wrap license
+UX500_FIRMWARE_LICENSE_FILES = license.txt
+UX500_FIRMWARE_REDISTRIBUTE = NO
+
+# The CG2900 linux driver has to load firmware named CG29XX_* but the firmware
+# filenames contained in this package are CG2900_* hence the code below
+define UX500_FIRMWARE_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+ for f in $(TARGET_DIR)/lib/firmware/CG2900* ; do \
+ mv $$f $${f/CG2900/CG29XX}; \
+ done
+endef
+
+$(eval $(generic-package))