summaryrefslogtreecommitdiffstats
path: root/package/util-linux
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-10-18 12:53:15 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-11-08 23:48:53 +0100
commit789a7cf4069b86f1bd44c55d69205aff1837f906 (patch)
tree1ed4b706b0fbb464e83e5379c28597f002000367 /package/util-linux
parentd7139cd936e0cb793dc552ddf484aacac1b8dd45 (diff)
downloadbuildroot-novena-789a7cf4069b86f1bd44c55d69205aff1837f906.tar.gz
buildroot-novena-789a7cf4069b86f1bd44c55d69205aff1837f906.zip
util-linux: fix partx build breakage
addpart, delpart and partx are enabled by default so --disable now to avoid build breaking when we lack libblkid. Also select libblkid when it's enabled now. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/util-linux')
-rw-r--r--package/util-linux/Config.in7
-rw-r--r--package/util-linux/util-linux.mk4
2 files changed, 6 insertions, 5 deletions
diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
index 816130daf..43a84440f 100644
--- a/package/util-linux/Config.in
+++ b/package/util-linux/Config.in
@@ -67,6 +67,10 @@ config BR2_PACKAGE_UTIL_LINUX_SCHEDUTILS
config BR2_PACKAGE_UTIL_LINUX_WALL
bool "build \"wall\""
+config BR2_PACKAGE_UTIL_LINUX_PARTX
+ bool "build \"addpart, delpart, partx\""
+ select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
+
############################################
# default disabled and should be enabled by
# --enable-foo
@@ -86,9 +90,6 @@ config BR2_PACKAGE_UTIL_LINUX_LAST
config BR2_PACKAGE_UTIL_LINUX_MESG
bool "build \"mesg\""
-config BR2_PACKAGE_UTIL_LINUX_PARTX
- bool "build \"addpart, delpart, partx\""
-
config BR2_PACKAGE_UTIL_LINUX_RAW
bool "build \"raw\""
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index b77e326f0..a3d6e139c 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -49,7 +49,8 @@ UTIL_LINUX_CONF_OPT += \
$(if $(BR2_PACKAGE_UTIL_LINUX_UNSHARE),,--disable-unshare) \
$(if $(BR2_PACKAGE_UTIL_LINUX_RENAME),,--disable-rename) \
$(if $(BR2_PACKAGE_UTIL_LINUX_SCHEDUTILS),,--disable-schedutils) \
- $(if $(BR2_PACKAGE_UTIL_LINUX_WALL),,--disable-wall)
+ $(if $(BR2_PACKAGE_UTIL_LINUX_WALL),,--disable-wall) \
+ $(if $(BR2_PACKAGE_UTIL_LINUX_PARTX),,--disable-partx)
#############################################
#
@@ -61,7 +62,6 @@ UTIL_LINUX_CONF_OPT += \
$(if $(BR2_PACKAGE_UTIL_LINUX_KILL),--enable-kill) \
$(if $(BR2_PACKAGE_UTIL_LINUX_LAST),--enable-last) \
$(if $(BR2_PACKAGE_UTIL_LINUX_MESG),--enable-mesg) \
- $(if $(BR2_PACKAGE_UTIL_LINUX_PARTX),--enable-partx) \
$(if $(BR2_PACKAGE_UTIL_LINUX_RAW),--enable-raw) \
$(if $(BR2_PACKAGE_UTIL_LINUX_RESET),--enable-reset) \
$(if $(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),--enable-login-utils) \