summaryrefslogtreecommitdiffstats
path: root/package/util-linux
diff options
context:
space:
mode:
authorChristophe Vu-Brugier <cvubrugier@lacie.com>2013-03-11 06:19:37 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-18 22:54:16 +0100
commit4123d76e76e26ab8af351b8f9af5fa8eb38bae2a (patch)
treea836f62dee2591bc7c77cbf1b5d0bc6ebe9833f9 /package/util-linux
parent28bb03ac9d6c8cb73dc01451efcc02c8b87b0456 (diff)
downloadbuildroot-novena-4123d76e76e26ab8af351b8f9af5fa8eb38bae2a.tar.gz
buildroot-novena-4123d76e76e26ab8af351b8f9af5fa8eb38bae2a.zip
host util-linux: disable login and su since they depend on PAM
This fixes the following errors when building util-linux v2.22.2 for the host in case the PAM headers are missing: configure: error: login selected, but required PAM header file not available configure: error: su selected, but required PAM header file not available Signed-off-by: Christophe Vu-Brugier <cvubrugier@lacie.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/util-linux')
-rw-r--r--package/util-linux/util-linux.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 5e8820604..b56220648 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -79,11 +79,12 @@ UTIL_LINUX_CONF_OPT += \
# and none of the util-linux utilities, so we disable all of them.
HOST_UTIL_LINUX_CONF_OPT += \
--enable-libuuid \
- --disable-mount --disable-fsck --disable-libmount \
- --disable-uuidd --disable-libblkid --disable-agetty \
- --disable-cramfs --disable-switch_root --disable-pivot_root \
- --disable-fallocate --disable-unshare --disable-rename \
- --disable-schedutils --disable-wall --disable-partx
+ --disable-agetty --disable-cramfs --disable-fallocate \
+ --disable-fsck --disable-libblkid --disable-libmount \
+ --disable-login --disable-mount --disable-partx \
+ --disable-pivot_root --disable-rename --disable-schedutils \
+ --disable-su --disable-switch_root --disable-unshare \
+ --disable-uuidd --disable-wall
# Avoid building the tools if they are disabled since we can't install on
# a per-directory basis.