summaryrefslogtreecommitdiffstats
path: root/package/usbredir
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-16 06:56:09 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 20:16:01 +0100
commit511d7317ad72fab84287f32c5a6872593d932d72 (patch)
treec1170f5f72e98e961c619fb7bd82e3958f66e597 /package/usbredir
parent8b2a81e267fac465064456469ec52c8897c2f59e (diff)
downloadbuildroot-novena-511d7317ad72fab84287f32c5a6872593d932d72.tar.gz
buildroot-novena-511d7317ad72fab84287f32c5a6872593d932d72.zip
package/usbredir: new package
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Peter Korsgaard <jacmet@uclibc.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/usbredir')
-rw-r--r--package/usbredir/Config.in29
-rw-r--r--package/usbredir/usbredir.mk29
2 files changed, 58 insertions, 0 deletions
diff --git a/package/usbredir/Config.in b/package/usbredir/Config.in
new file mode 100644
index 000000000..e2a71840a
--- /dev/null
+++ b/package/usbredir/Config.in
@@ -0,0 +1,29 @@
+comment "usbredir needs a toolchain with threads"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
+
+config BR2_PACKAGE_USBREDIR
+ bool "usbredir"
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+ select BR2_PACKAGE_LIBUSB
+ help
+ usbredir is the name of a network protocol for sending usb device
+ traffic over a network connection. It is also the name of the
+ software package offering a parsing library, a usbredirhost library
+ and several utilities implementing this protocol.
+
+ Note: only the library is installed, not the utilities. Say 'y'
+ below if you want the server too.
+
+ http://www.spice-space.org/page/UsbRedir
+
+if BR2_PACKAGE_USBREDIR
+
+config BR2_PACKAGE_USBREDIR_SERVER
+ bool "usbredirserver on target"
+ help
+ If you want to serve usbredir requests on your target, say 'y'
+ here to have the usbredir server on the target.
+
+ Note: the server is not required to use the library.
+
+endif
diff --git a/package/usbredir/usbredir.mk b/package/usbredir/usbredir.mk
new file mode 100644
index 000000000..ac98472b5
--- /dev/null
+++ b/package/usbredir/usbredir.mk
@@ -0,0 +1,29 @@
+#############################################################
+#
+# usbredir
+#
+#############################################################
+
+USBREDIR_VERSION = 0.4.3
+USBREDIR_SOURCE = usbredir-$(USBREDIR_VERSION).tar.bz2
+USBREDIR_SITE = http://spice-space.org/download/usbredir
+USBREDIR_LICENSE = LGPLv2.1+
+USBREDIR_LICENSE_FILES = COPYING.LIB
+USBREDIR_INSTALL_STAGING = YES
+USBREDIR_DEPENDENCIES = host-pkgconf libusb
+
+ifeq ($(BR2_PACKAGE_USBREDIR_SERVER),y)
+
+USBREDIR_LICENSE += (for the library), GPLv2+ (for the server)
+USBREDIR_LICENSE_FILES += COPYING
+
+else # BR2_PACKAGE_USBREDIR_SERVER != y
+
+define USBREDIR_POST_INSTALL_TARGET_RM_SERVER
+ rm -f $(TARGET_DIR)/usr/sbin/usbredirserver
+endef
+USBREDIR_POST_INSTALL_TARGET_HOOKS += USBREDIR_POST_INSTALL_TARGET_RM_SERVER
+
+endif # BR2_PACKAGE_USBREDIR_SERVER
+
+$(eval $(autotools-package))