summaryrefslogtreecommitdiffstats
path: root/package/urg
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-17 22:36:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-18 09:46:02 +0100
commite7d8d855f0ab28d6cd608b7204a9e13a18b15092 (patch)
tree51822a2247e2c39208b40c64b51196dc8a23601d /package/urg
parentffa779564e6367a2133f0a3e7bd5bd070287dbbb (diff)
downloadbuildroot-novena-e7d8d855f0ab28d6cd608b7204a9e13a18b15092.tar.gz
buildroot-novena-e7d8d855f0ab28d6cd608b7204a9e13a18b15092.zip
urg: handle config scripts properly
urg installs two <foo>-config scripts, so the ones installed in $(STAGING_DIR) should be fixed up, and the ones installed in $(TARGET_DIR) should be removed. Use the <pkg>_CONFIG_SCRIPTS infrastructure to do this. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/urg')
-rw-r--r--package/urg/urg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/urg/urg.mk b/package/urg/urg.mk
index b544ece8e..99f63a9cd 100644
--- a/package/urg/urg.mk
+++ b/package/urg/urg.mk
@@ -17,6 +17,8 @@ URG_DEPENDENCIES = sdl sdl_net
URG_CONF_OPT = --with-sdl-prefix=$(STAGING_DIR)/usr \
--with-sdl-exec-prefix=$(STAGING_DIR)/usr
+URG_CONFIG_SCRIPTS = c_urg-config urg-config
+
define URG_EXTRACT_CMDS
$(RM) -rf $(URG_DIR)
unzip -q -d $(BUILD_DIR)/ $(DL_DIR)/$(URG_SOURCE)