summaryrefslogtreecommitdiffstats
path: root/package/unionfs
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-10-13 01:46:09 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-13 22:22:44 +0200
commitee1dd812881cc7928e11addaa18e8185d2b02000 (patch)
tree9c9a48aab4ffdce1ec1fd016e7d7d2719393d250 /package/unionfs
parent26e73ecb4540a4e78e92abaa9855e816b6dbf77f (diff)
downloadbuildroot-novena-ee1dd812881cc7928e11addaa18e8185d2b02000.tar.gz
buildroot-novena-ee1dd812881cc7928e11addaa18e8185d2b02000.zip
unionfs: convert to cmake-package
Fixes e.g. http://autobuild.buildroot.net/results/c279007dd8b89a1c6fc9b58d3c2cda01ab84279e The addition of CPPFLAGS overrides the defines added in unionfs's Makefile. Since unionfs now has CMake support, use that instead. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/unionfs')
-rw-r--r--package/unionfs/unionfs.mk10
1 files changed, 1 insertions, 9 deletions
diff --git a/package/unionfs/unionfs.mk b/package/unionfs/unionfs.mk
index eb8109ecb..6c86c57c3 100644
--- a/package/unionfs/unionfs.mk
+++ b/package/unionfs/unionfs.mk
@@ -11,12 +11,4 @@ UNIONFS_DEPENDENCIES = libfuse host-pkg-config
UNIONFS_LICENSE = BSD-3c
UNIONFS_LICENSE_FILES = LICENSE
-define UNIONFS_BUILD_CMDS
- $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
-endef
-
-define UNIONFS_INSTALL_TARGET_CMDS
- $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) install
-endef
-
-$(eval $(generic-package))
+$(eval $(cmake-package))