summaryrefslogtreecommitdiffstats
path: root/package/unionfs/unionfs.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-01-11 11:11:58 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-11 15:36:27 +0100
commit7360f16a22af3e0a1a2e5891a275a7c86e7e5cc3 (patch)
tree3afeb1b9968cc99ec649d627414b8742a9a9080c /package/unionfs/unionfs.mk
parentdda08e492d724e0bbe5896b1c97b5a8ea1b40b59 (diff)
downloadbuildroot-novena-7360f16a22af3e0a1a2e5891a275a7c86e7e5cc3.tar.gz
buildroot-novena-7360f16a22af3e0a1a2e5891a275a7c86e7e5cc3.zip
unionfs: new package
Add the unionfs FUSE unification filesystem. [Peter: whitespace/help text fix] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/unionfs/unionfs.mk')
-rw-r--r--package/unionfs/unionfs.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/unionfs/unionfs.mk b/package/unionfs/unionfs.mk
new file mode 100644
index 000000000..b0bc93b56
--- /dev/null
+++ b/package/unionfs/unionfs.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# unionfs
+#
+#############################################################
+
+UNIONFS_VERSION = 0.24
+UNIONFS_SITE = http://podgorny.cz/unionfs-fuse/releases
+UNIONFS_SOURCE = unionfs-fuse-$(UNIONFS_VERSION).tar.bz2
+UNIONFS_DEPENDENCIES = libfuse
+
+define UNIONFS_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define UNIONFS_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(call GENTARGETS))