summaryrefslogtreecommitdiffstats
path: root/package/uboot-tools
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-19 01:04:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-19 19:23:45 +0100
commit7bf847b5373b7833c5a83ed6c9afc57bc0afe13b (patch)
tree4600f4d22bd58b0d60db82710fded839ceefb0f6 /package/uboot-tools
parent95a5ed51ba1fdfed72739a4c05c57bf3f8d17a90 (diff)
downloadbuildroot-novena-7bf847b5373b7833c5a83ed6c9afc57bc0afe13b.tar.gz
buildroot-novena-7bf847b5373b7833c5a83ed6c9afc57bc0afe13b.zip
uboot-tools: fix build failure for the target
The patch to drop config.h is still required, it just needed a tweak. Fixes: http://autobuild.buildroot.net/results/3653c0e3ec460c710524468987d5192337cf210e/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/uboot-tools')
-rw-r--r--package/uboot-tools/uboot-tools-drop-configh-from-tools.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch b/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch
new file mode 100644
index 000000000..21995ecf0
--- /dev/null
+++ b/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch
@@ -0,0 +1,37 @@
+We need to build u-boot tools without a board configuration for the target.
+fw_env just uses config.h to define the default environment of the created
+image, so it really isn't mandatory.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura u-boot-2013.01.orig/tools/env/fw_env.h u-boot-2013.01/tools/env/fw_env.h
+--- u-boot-2013.01.orig/tools/env/fw_env.h 2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/fw_env.h 2013-01-19 07:58:11.897903403 -0300
+@@ -21,15 +21,6 @@
+ * MA 02111-1307 USA
+ */
+
+-/* Pull in the current config to define the default environment */
+-#ifndef __ASSEMBLY__
+-#define __ASSEMBLY__ /* get only #defines from config.h */
+-#include <config.h>
+-#undef __ASSEMBLY__
+-#else
+-#include <config.h>
+-#endif
+-
+ /*
+ * To build the utility with the static configuration
+ * comment out the next line.
+diff -Nura u-boot-2013.01.orig/tools/env/Makefile u-boot-2013.01/tools/env/Makefile
+--- u-boot-2013.01.orig/tools/env/Makefile 2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/Makefile 2013-01-19 07:59:34.926486346 -0300
+@@ -26,7 +26,7 @@
+ HOSTSRCS := $(SRCTREE)/lib/crc32.c fw_env.c fw_env_main.c
+ HOSTSRCS += $(SRCTREE)/lib/ctype.c $(SRCTREE)/lib/linux_string.c
+ HOSTSRCS += $(SRCTREE)/common/env_attr.c $(SRCTREE)/common/env_flags.c
+-HEADERS := fw_env.h $(OBJTREE)/include/config.h
++HEADERS := fw_env.h
+
+ # Compile for a hosted environment on the target
+ HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \