summaryrefslogtreecommitdiffstats
path: root/package/uboot-tools
diff options
context:
space:
mode:
authorHenri Bragge <henri.bragge@gmail.com>2011-12-16 22:08:59 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-17 22:31:51 +0100
commit54b2f131067003fc53240b9bd4497a25c145591a (patch)
tree6016e709d90ce6afff6d05a11f8f8ff8ace453e0 /package/uboot-tools
parentc8041ee7d85c9676e52679e53abbbf7e1fa50415 (diff)
downloadbuildroot-novena-54b2f131067003fc53240b9bd4497a25c145591a.tar.gz
buildroot-novena-54b2f131067003fc53240b9bd4497a25c145591a.zip
uboot-tools: fix install commands
Signed-off-by: Henri Bragge <henri.bragge@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/uboot-tools')
-rw-r--r--package/uboot-tools/uboot-tools.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/uboot-tools/uboot-tools.mk b/package/uboot-tools/uboot-tools.mk
index e20560ab2..00592d6eb 100644
--- a/package/uboot-tools/uboot-tools.mk
+++ b/package/uboot-tools/uboot-tools.mk
@@ -13,13 +13,13 @@ endef
ifeq ($(BR2_PACKAGE_UBOOT_TOOLS_MKIMAGE),y)
define UBOOT_TOOLS_INSTALL_MKIMAGE
- install -m 0755 -D $(@D)/tools/mkimage $(TARGET_DIR)/usr/bin
+ $(INSTALL) -m 0755 -D $(@D)/tools/mkimage $(TARGET_DIR)/usr/bin/mkimage
endef
endif
ifeq ($(BR2_PACKAGE_UBOOT_TOOLS_FWPRINTENV),y)
define UBOOT_TOOLS_INSTALL_FWPRINTENV
- install -m 0755 -D $(@D)/tools/env/fw_printenv $(TARGET_DIR)/usr/sbin
+ $(INSTALL) -m 0755 -D $(@D)/tools/env/fw_printenv $(TARGET_DIR)/usr/sbin/fw_printenv
ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv
endef
endif
@@ -48,7 +48,7 @@ define HOST_UBOOT_TOOLS_BUILD_CMDS
endef
define HOST_UBOOT_TOOLS_INSTALL_CMDS
- install -m 0755 -D $(@D)/tools/mkimage $(HOST_DIR)/usr/bin
+ $(INSTALL) -m 0755 -D $(@D)/tools/mkimage $(HOST_DIR)/usr/bin/mkimage
endef
$(eval $(call GENTARGETS))