summaryrefslogtreecommitdiffstats
path: root/package/tvheadend/tvheadend.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-28 12:37:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-28 23:40:26 +0100
commit14989d0be59762a354e7c5c15a2eeb4826d8040b (patch)
treef47c0c5725cecb619552786fafad18d9fe5c924b /package/tvheadend/tvheadend.mk
parent6904b0ea954c22f3efb9619dc4a7b793fe985547 (diff)
downloadbuildroot-novena-14989d0be59762a354e7c5c15a2eeb4826d8040b.tar.gz
buildroot-novena-14989d0be59762a354e7c5c15a2eeb4826d8040b.zip
package/tvheadend: new package
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tvheadend/tvheadend.mk')
-rw-r--r--package/tvheadend/tvheadend.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/tvheadend/tvheadend.mk b/package/tvheadend/tvheadend.mk
new file mode 100644
index 000000000..51007812c
--- /dev/null
+++ b/package/tvheadend/tvheadend.mk
@@ -0,0 +1,43 @@
+#############################################################
+#
+# tvheadend
+#
+##############################################################
+
+TVHEADEND_VERSION = v3.3
+TVHEADEND_SITE = http://github.com/tvheadend/tvheadend/tarball/$(TVHEADEND_VERSION)
+TVHEADEND_LICENSE = GPLv3+
+TVHEADEND_LICENSE_FILES = LICENSE
+TVHEADEND_DEPENDENCIES = host-pkgconf host-python openssl
+
+ifeq ($(BR2_PACKAGE_AVAHI),y)
+TVHEADEND_DEPENDENCIES += avahi
+endif
+
+#----------------------------------------------------------------------------
+# tvheadend is a little smuggler and thief! ;-)
+# During the ./configure, it downloads some files from the dvb-apps
+# package, so it has a list of pre-scanned tunner configurations.
+# For buildroot, we add a patch that avoids doing that, but uses the
+# scan files installed by the dvb-apps package
+TVHEADEND_DEPENDENCIES += dvb-apps
+
+#----------------------------------------------------------------------------
+# To run tvheadend, we need:
+# - a startup script, and its config file
+# - a default DB with a tvheadend admin
+define TVHEADEND_INSTALL_DB
+ $(INSTALL) -D package/tvheadend/accesscontrol.1 \
+ $(TARGET_DIR)/root/.hts/tvheadend/accesscontrol/1
+endef
+TVHEADEND_POST_INSTALL_TARGET_HOOKS = TVHEADEND_INSTALL_DB
+
+define TVHEADEND_INSTALL_INIT_SYSV
+ $(INSTALL) -D package/tvheadend/etc.default.tvheadend $(TARGET_DIR)/etc/default/tvheadend
+ $(INSTALL) -D package/tvheadend/S99tvheadend $(TARGET_DIR)/etc/init.d/S99tvheadend
+endef
+
+#----------------------------------------------------------------------------
+# tvheadend is not an autotools-based package, but it is possible to
+# call its ./configure script as if it were an autotools one.
+$(eval $(autotools-package))