summaryrefslogtreecommitdiffstats
path: root/package/tvheadend/tvheadend-001-no-auto-download-dvbscans.patch
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-02-17 13:22:28 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-22 23:34:39 +0100
commit4667e1cb86ebcad372c61c72c8ad0f15a30d0552 (patch)
tree3843277105d8f18080910fffd61403c3af375030 /package/tvheadend/tvheadend-001-no-auto-download-dvbscans.patch
parent7f68a28d78eee37dd32f0fcf9083e86ad1e79485 (diff)
downloadbuildroot-novena-4667e1cb86ebcad372c61c72c8ad0f15a30d0552.tar.gz
buildroot-novena-4667e1cb86ebcad372c61c72c8ad0f15a30d0552.zip
package/tvheadend: update to v3.5
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tvheadend/tvheadend-001-no-auto-download-dvbscans.patch')
-rw-r--r--package/tvheadend/tvheadend-001-no-auto-download-dvbscans.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/package/tvheadend/tvheadend-001-no-auto-download-dvbscans.patch b/package/tvheadend/tvheadend-001-no-auto-download-dvbscans.patch
new file mode 100644
index 000000000..cc25c564c
--- /dev/null
+++ b/package/tvheadend/tvheadend-001-no-auto-download-dvbscans.patch
@@ -0,0 +1,66 @@
+Do not download transponder data as part of the build
+
+If dvb-scan is enabled, tvheadend will download the transponders data
+from the dvb-apps package. This does not play well with buildroot.
+
+Instead, we rely on the dvb-apps package to install those files, so
+it is no longer needed to install those as part of tvheadend.
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+diff -durN tvheadend-v3.5.orig/configure tvheadend-v3.5/configure
+--- tvheadend-v3.5.orig/configure 2013-02-15 14:41:26.000000000 +0100
++++ tvheadend-v3.5/configure 2013-02-16 15:41:16.675556099 +0100
+@@ -178,15 +178,16 @@
+ #
+ # DVB scan
+ #
+-if enabled linuxdvb && enabled dvbscan; then
+- printf "${TAB}" "fetching dvb-scan files ..."
+- ${ROOTDIR}/support/getmuxlist
+- if [ $? -ne 0 ]; then
+- echo "fail"
+- die "Failed to fetch dvb-scan data (use --disable-dvbscan)"
+- fi
+- echo "ok"
+-fi
++# For buildroot, we already installed those files via the dvb-apps package
++#if enabled linuxdvb && enabled dvbscan; then
++# printf "${TAB}" "fetching dvb-scan files ..."
++# ${ROOTDIR}/support/getmuxlist
++# if [ $? -ne 0 ]; then
++# echo "fail"
++# die "Failed to fetch dvb-scan data (use --disable-dvbscan)"
++# fi
++# echo "ok"
++#fi
+
+ # ###########################################################################
+ # Write config
+Binary files tvheadend-v3.5.orig/.configure.swp and tvheadend-v3.5/.configure.swp differ
+diff -durN tvheadend-v3.5.orig/Makefile tvheadend-v3.5/Makefile
+--- tvheadend-v3.5.orig/Makefile 2013-02-15 14:41:26.000000000 +0100
++++ tvheadend-v3.5/Makefile 2013-02-16 15:41:38.218821287 +0100
+@@ -207,7 +207,7 @@
+ SRCS-${CONFIG_BUNDLE} += bundle.c
+ BUNDLES-yes += docs/html docs/docresources src/webui/static
+ BUNDLES-yes += data/conf
+-BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
++#BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
+ BUNDLES = $(BUNDLES-yes)
+
+ #
+diff -durN tvheadend-v3.5.orig/support/posix.mk tvheadend-v3.5/support/posix.mk
+--- tvheadend-v3.5.orig/support/posix.mk 2013-02-15 14:41:26.000000000 +0100
++++ tvheadend-v3.5/support/posix.mk 2013-02-16 15:42:41.015290003 +0100
+@@ -15,6 +15,10 @@
+
+ find ${DESTDIR}${datadir}/tvheadend -name .git -exec rm -rf {} \; &>/dev/null || /bin/true
+
++ mkdir -p ${DESTDIR}${datadir}/tvheadend/data
++ rm -f ${DESTDIR}${datadir}/tvheadend/data/dvb-scan
++ ln -sf /usr/share/dvb ${DESTDIR}${datadir}/tvheadend/data/dvb-scan
++
+ uninstall:
+ rm -f ${DESTDIR}${bindir)/tvheadend
+ rm -f ${DESTDIR}${mandir)/tvheadend.1