summaryrefslogtreecommitdiffstats
path: root/package/tslib
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-04 16:47:19 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-04 16:47:19 +0000
commitb7ff212c81ab88cc2d4e23e149bc2d63ff5a6373 (patch)
tree5dd3c3915c9f043cbfcd4fd349dfc1dfac3e7565 /package/tslib
parent62cc77dffdd60900d8ed7511ad8319ef39092a6b (diff)
downloadbuildroot-novena-b7ff212c81ab88cc2d4e23e149bc2d63ff5a6373.tar.gz
buildroot-novena-b7ff212c81ab88cc2d4e23e149bc2d63ff5a6373.zip
tslib: add dependency to hsot-autoconf and host-automake
Tslib uses autoconf and automake during configure section, make sure it is available before building tslib.
Diffstat (limited to 'package/tslib')
-rw-r--r--package/tslib/tslib.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/tslib/tslib.mk b/package/tslib/tslib.mk
index 0ff37c3f5..092afa3c6 100644
--- a/package/tslib/tslib.mk
+++ b/package/tslib/tslib.mk
@@ -20,7 +20,7 @@ $(TSLIB_DIR)/.patched: $(DL_DIR)/$(TSLIB_SOURCE)
touch $@
$(TSLIB_DIR)/.configured: $(TSLIB_DIR)/.patched
- (cd $(TSLIB_DIR); rm -rf config.cache; ./autogen.sh)
+ (cd $(TSLIB_DIR); rm -rf config.cache; PATH=$(TARGET_PATH) ./autogen.sh)
$(CONFIG_UPDATE) $(TSLIB_DIR)
(cd $(TSLIB_DIR) && \
$(TARGET_CONFIGURE_OPTS) \
@@ -84,7 +84,7 @@ $(TARGET_DIR)/usr/lib/libts.so: $(STAGING_DIR)/usr/lib/libts.so
-$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/bin/ts_test
cp -dpf package/tslib/ts.conf $(TARGET_DIR)/etc/
-tslib: uclibc $(TARGET_DIR)/usr/lib/libts.so
+tslib: uclibc host-automake host-autoconf $(TARGET_DIR)/usr/lib/libts.so
tslib-build: uclibc $(TSLIB_DIR)/.configured
rm -f $(TSLIB_DIR)/.compiled