summaryrefslogtreecommitdiffstats
path: root/package/tree
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-06 16:38:04 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-06 16:38:04 +0200
commitf7c5d92314061ff68c8f12d0788f65b1d979cf11 (patch)
treef67681b9b6c99015c76f5e75441980692c7ece06 /package/tree
parentd8587c198b523f66668969b8cd555ba65938693c (diff)
downloadbuildroot-novena-f7c5d92314061ff68c8f12d0788f65b1d979cf11.tar.gz
buildroot-novena-f7c5d92314061ff68c8f12d0788f65b1d979cf11.zip
package: add tree
Tree is a recursive directory listing command that produces a depth indented listing of files. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tree')
-rw-r--r--package/tree/Config.in13
-rw-r--r--package/tree/tree.mk27
2 files changed, 40 insertions, 0 deletions
diff --git a/package/tree/Config.in b/package/tree/Config.in
new file mode 100644
index 000000000..b6e21c87c
--- /dev/null
+++ b/package/tree/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_TREE
+ bool "tree"
+ depends on BR2_USE_WCHAR
+ help
+ Tree is a recursive directory listing command that produces
+ a depth indented listing of files, which is colorized ala
+ dircolors if the LS_COLORS environment variable is set and
+ output is to tty.
+
+ http://mama.indstate.edu/users/ice/tree/
+
+comment "tree requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
diff --git a/package/tree/tree.mk b/package/tree/tree.mk
new file mode 100644
index 000000000..509ba4531
--- /dev/null
+++ b/package/tree/tree.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# tree
+#
+################################################################################
+
+TREE_VERSION = 1.6.0
+TREE_SOURCE = tree-$(TREE_VERSION).tgz
+TREE_SITE = http://mama.indstate.edu/users/ice/tree/src/
+TREE_LICENSE = GPLv2+
+TREE_LICENSE_FILES = LICENSE
+
+define TREE_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define TREE_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/tree $(TARGET_DIR)/usr/bin/tree
+ $(INSTALL) -D -m 0644 $(@D)/doc/tree.1 \
+ $(TARGET_DIR)/usr/share/man/man1/tree.1
+endef
+
+define TREE_CLEAN_CMDS
+ -$(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))