summaryrefslogtreecommitdiffstats
path: root/package/tinymembench
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-27 13:55:27 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-27 13:55:27 +0200
commit4e0676c4848c03c7a25a99699d1c0390387d9d1b (patch)
treeb8de533898102524c0f4b5bc88c23d451e71780a /package/tinymembench
parent30c315d6423470eb2ce2ce968facb21410a22bdd (diff)
downloadbuildroot-novena-4e0676c4848c03c7a25a99699d1c0390387d9d1b.tar.gz
buildroot-novena-4e0676c4848c03c7a25a99699d1c0390387d9d1b.zip
package: add tinymembench
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tinymembench')
-rw-r--r--package/tinymembench/Config.in11
-rw-r--r--package/tinymembench/tinymembench.mk22
2 files changed, 33 insertions, 0 deletions
diff --git a/package/tinymembench/Config.in b/package/tinymembench/Config.in
new file mode 100644
index 000000000..0d45532e2
--- /dev/null
+++ b/package/tinymembench/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_TINYMEMBENCH
+ bool "tinymembench"
+ help
+ Tinymembench is a simple memory benchmark program, which
+ tries to measure the peak bandwidth of sequential memory
+ accesses and the latency of random memory accesses.
+ Bandwidth is measured by running different assembly code for
+ the aligned memory blocks and attempting different prefetch
+ strategies.
+
+ https://github.com/ssvb/tinymembench
diff --git a/package/tinymembench/tinymembench.mk b/package/tinymembench/tinymembench.mk
new file mode 100644
index 000000000..285d1fdbe
--- /dev/null
+++ b/package/tinymembench/tinymembench.mk
@@ -0,0 +1,22 @@
+################################################################################
+#
+# tinymembench
+#
+################################################################################
+
+TINYMEMBENCH_VERSION = v0.2
+TINYMEMBENCH_SITE = http://github.com/ssvb/tinymembench/tarball/$(TINYMEMBENCH_VERSION)
+TINYMEMBENCH_LICENSE = MIT
+TINYMEMBENCH_LICENSE_FILES = main.c
+
+define TINYMEMBENCH_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define TINYMEMBENCH_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/tinymembench \
+ $(TARGET_DIR)/usr/bin/tinymembench
+endef
+
+$(eval $(generic-package))
+