summaryrefslogtreecommitdiffstats
path: root/package/tinyhttpd
diff options
context:
space:
mode:
authorgilles.talis@gmail.com <gilles.talis@gmail.com>2013-06-21 10:59:44 -0700
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-23 21:47:15 +0200
commitc3cf32ebf55c203ec4d3fcd566ca64bf173b9079 (patch)
treeb30a5761293abc2a0c55f377948e48a8fe790b10 /package/tinyhttpd
parent953430bc4dcf7e8691252b3a60d10d6ff72db5c9 (diff)
downloadbuildroot-novena-c3cf32ebf55c203ec4d3fcd566ca64bf173b9079.tar.gz
buildroot-novena-c3cf32ebf55c203ec4d3fcd566ca64bf173b9079.zip
tinyhttpd: do not link against pthread
Original patch for tinyhttpd disables pthread support from the code but does not disable it from makefile. This patch disables pthread support altogether Fixes: http://autobuild.buildroot.net/results/2e61a80fcbddd62c76e0406c34ab44d14a4b5c79 Signed-off-by: Gilles Talis <gilles.talis@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/tinyhttpd')
-rw-r--r--package/tinyhttpd/tinyhttpd.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/tinyhttpd/tinyhttpd.patch b/package/tinyhttpd/tinyhttpd.patch
index 02eb189af..05d6e50a7 100644
--- a/package/tinyhttpd/tinyhttpd.patch
+++ b/package/tinyhttpd/tinyhttpd.patch
@@ -73,7 +73,7 @@ diff -ur tinyhttpd-0.1.0/Makefile tinyhttpd-0.1.0-patched/Makefile
httpd: httpd.c
- gcc -W -Wall -lsocket -lpthread -o httpd httpd.c
-+ $(CC) $(CFLAGS) $(LDFLAGS) -W -Wall -lpthread -o httpd httpd.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -W -Wall -o httpd httpd.c
clean:
- rm httpd