summaryrefslogtreecommitdiffstats
path: root/package/tiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 23:10:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:26:50 +0200
commit0958e6109c9ed8c82342d17a1205e3c4b8baa3f0 (patch)
treee1a16a6545621b4f1f224541b55addbde2743f64 /package/tiff
parent62df009e47bb0f850989aaba24b08d06d5b03305 (diff)
downloadbuildroot-novena-0958e6109c9ed8c82342d17a1205e3c4b8baa3f0.tar.gz
buildroot-novena-0958e6109c9ed8c82342d17a1205e3c4b8baa3f0.zip
tiff: use correct construct to override target installation
We also remove the stripping, as it is already done globally. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tiff')
-rw-r--r--package/tiff/tiff.mk10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/tiff/tiff.mk b/package/tiff/tiff.mk
index 8db215ee5..ca6f562af 100644
--- a/package/tiff/tiff.mk
+++ b/package/tiff/tiff.mk
@@ -17,10 +17,8 @@ TIFF_CONF_OPT = \
TIFF_DEPENDENCIES = host-pkg-config zlib jpeg
-$(eval $(call AUTOTARGETS,package,tiff))
-
-$(TIFF_TARGET_INSTALL_TARGET):
- -cp -a $(TIFF_DIR)/libtiff/.libs/libtiff.so* $(TARGET_DIR)/usr/lib/
- $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libtiff.so
- touch $@
+define TIFF_INSTALL_TARGET_CMDS
+ -cp -a $(@D)/libtiff/.libs/libtiff.so* $(TARGET_DIR)/usr/lib/
+endef
+$(eval $(call AUTOTARGETS,package,tiff))