summaryrefslogtreecommitdiffstats
path: root/package/ti-utils
diff options
context:
space:
mode:
authorYegor Yefremov <yegor_sub1@visionsystems.de>2011-04-27 10:32:48 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-25 13:50:38 +0200
commitafce67a9029dbcc1eec0b011ed2daa4559455310 (patch)
tree496085d9200d7f1d61aa2f81e3aac6999cae9713 /package/ti-utils
parentb96193a4b53e0c6661c722aa4e91e7cfb7608cef (diff)
downloadbuildroot-novena-afce67a9029dbcc1eec0b011ed2daa4559455310.tar.gz
buildroot-novena-afce67a9029dbcc1eec0b011ed2daa4559455310.zip
New package: ti-utils
Add the calibrator and other useful utilities for TI wireless solution, based on wl12xx driver. See http://linuxwireless.org/en/users/Drivers/wl12xx/calibrator for further details. [Peter: add libnl Config.in dependency] Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ti-utils')
-rw-r--r--package/ti-utils/Config.in8
-rw-r--r--package/ti-utils/ti-utils.mk29
2 files changed, 37 insertions, 0 deletions
diff --git a/package/ti-utils/Config.in b/package/ti-utils/Config.in
new file mode 100644
index 000000000..02ae336dc
--- /dev/null
+++ b/package/ti-utils/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_TI_UTILS
+ bool "ti-utils"
+ select BR2_PACKAGE_LIBNL
+ help
+ The calibrator and other useful utilities for TI wireless solution,
+ based on wl12xx driver.
+
+ http://linuxwireless.org/en/users/Drivers/wl12xx/calibrator
diff --git a/package/ti-utils/ti-utils.mk b/package/ti-utils/ti-utils.mk
new file mode 100644
index 000000000..8f35b5922
--- /dev/null
+++ b/package/ti-utils/ti-utils.mk
@@ -0,0 +1,29 @@
+#############################################################
+#
+# ti-utils
+#
+#############################################################
+
+TI_UTILS_VERSION = fbceab8f228cff80fd29b830bb85a188c69def08
+TI_UTILS_SITE = git://github.com/gxk/ti-utils.git
+TI_UTILS_DEPENDENCIES = libnl
+
+define TI_UTILS_BUILD_CMDS
+ $(MAKE1) NFSROOT="$(STAGING_DIR)" CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
+ -C $(@D) all
+endef
+
+define TI_UTILS_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 $(@D)/calibrator \
+ $(TARGET_DIR)/usr/bin/calibrator
+ $(INSTALL) -m 0755 $(@D)/scripts/go.sh \
+ $(TARGET_DIR)/usr/bin/go.sh
+endef
+
+define TI_UTILS_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/bin/calibrator
+ rm -f $(TARGET_DIR)/usr/bin/go.sh
+endef
+
+$(eval $(call GENTARGETS,package,ti-utils))
+