summaryrefslogtreecommitdiffstats
path: root/package/thttpd/thttpd.mk
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-20 14:37:48 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-20 14:37:48 +0000
commit0ffc8419b44179821f2f86fe9fb6e89543405be2 (patch)
tree6b000e3298def6357c6ce3ea72d4f069b1a6785b /package/thttpd/thttpd.mk
parent4ccf17da47f4823e658900bcbfa598b255f5575a (diff)
downloadbuildroot-novena-0ffc8419b44179821f2f86fe9fb6e89543405be2.tar.gz
buildroot-novena-0ffc8419b44179821f2f86fe9fb6e89543405be2.zip
Fix hdparm to cross build correctly. Also fix thttpd to build and install sanely and add simplified start up.
Diffstat (limited to 'package/thttpd/thttpd.mk')
-rw-r--r--package/thttpd/thttpd.mk40
1 files changed, 11 insertions, 29 deletions
diff --git a/package/thttpd/thttpd.mk b/package/thttpd/thttpd.mk
index 3c676d18c..4132fcbfd 100644
--- a/package/thttpd/thttpd.mk
+++ b/package/thttpd/thttpd.mk
@@ -9,9 +9,8 @@ THTTPD_SITE:=http://www.acme.com/software/thttpd/
THTTPD_DIR:=$(BUILD_DIR)/thttpd-$(THTTPD_VERSION)
THTTPD_CAT:=$(ZCAT)
THTTPD_BINARY:=thttpd
-THTTPD_TARGET_BINARY:=sbin/thttpd
-THTTPD_ROOT:=/var
-THTTPD_WEB_DIR:=$(THTTPD_ROOT)/www
+THTTPD_TARGET_BINARY:=usr/sbin/thttpd
+THTTPD_WEB_DIR:=/var/www
$(DL_DIR)/$(THTTPD_SOURCE):
$(WGET) -P $(DL_DIR) $(THTTPD_SITE)/$(THTTPD_SOURCE)
@@ -30,48 +29,31 @@ $(THTTPD_DIR)/.configured: $(THTTPD_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
- --prefix=$(THTTPD_ROOT) \
+ --prefix=/usr \
);
touch $(THTTPD_DIR)/.configured
$(THTTPD_DIR)/$(THTTPD_BINARY): $(THTTPD_DIR)/.configured
- $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(THTTPD_DIR)
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) WEBDIR=$(THTTPD_WEB_DIR) -C $(THTTPD_DIR)
$(TARGET_DIR)/$(THTTPD_TARGET_BINARY): $(THTTPD_DIR)/$(THTTPD_BINARY)
- install -D $(THTTPD_DIR)/$(THTTPD_BINARY) $(TARGET_DIR)/$(THTTPD_TARGET_BINARY)
- install -D $(THTTPD_DIR)/extras/htpasswd $(TARGET_DIR)/bin/htpasswd
- install -D $(THTTPD_DIR)/extras/makeweb $(TARGET_DIR)/bin/makeweb
- install -D $(THTTPD_DIR)/extras/syslogtocern $(TARGET_DIR)/bin/syslogtocern
- install -D $(THTTPD_DIR)/scripts/thttpd_wrapper $(TARGET_DIR)/sbin/thttpd_wrapper
- install -D $(THTTPD_DIR)/scripts/thttpd.sh $(TARGET_DIR)/etc/init.d/S90thttpd
- cp $(TARGET_DIR)/etc/init.d/S90thttpd $(TARGET_DIR)/etc/init.d/S90thttpd.in
- cp $(TARGET_DIR)/sbin/thttpd_wrapper $(TARGET_DIR)/sbin/thttpd_wrapper.in
- sed -e "s:/usr/local/sbin:/sbin:g" -e "s:/usr/local/www:$(THTTPD_WEB_DIR):g" < $(TARGET_DIR)/sbin/thttpd_wrapper.in > $(TARGET_DIR)/sbin/httpd_wrapper
- sed -e "s:/usr/local/sbin:/sbin:g" < $(TARGET_DIR)/etc/init.d/S90thttpd.in > $(TARGET_DIR)/etc/init.d/S90thttpd
- rm -f $(TARGET_DIR)/etc/init.d/S90thttpd.in $(TARGET_DIR)/sbin/thttpd_wrapper.in
- install -d $(TARGET_DIR)$(THTTPD_WEB_DIR)/data
- install -d $(TARGET_DIR)$(THTTPD_WEB_DIR)/logs
- echo "dir=$(THTTPD_WEB_DIR)/data" > $(TARGET_DIR)$(THTTPD_WEB_DIR)/thttpd_config
- echo 'cgipat=**.cgi' >> $(TARGET_DIR)$(THTTPD_WEB_DIR)/thttpd_config
- echo "logfile=$(THTTPD_WEB_DIR)/logs/thttpd_log" >> $(TARGET_DIR)$(THTTPD_WEB_DIR)/thttpd_config
- echo "pidfile=/var/run/thttpd.pid" >> $(TARGET_DIR)$(THTTPD_WEB_DIR)/thttpd_config
- echo "<HTML><BODY>thttpd test page</BODY></HTML>" > $(TARGET_DIR)$(THTTPD_WEB_DIR)/data/index.html
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) prefix=$(TARGET_DIR)/usr WEBDIR=$(THTTPD_WEB_DIR) -C $(THTTPD_DIR) installthis
+ $(STRIP) --strip-unneeded $(THTTPD_DIR)/$(THTTPD_BINARY)
+ $(INSTALL) -d $(TARGET_DIR)$(THTTPD_WEB_DIR)/cgi-bin
+ $(INSTALL) -m 0755 package/thttpd/S90thttpd $(TARGET_DIR)/etc/init.d
+ $(INSTALL) -m 0644 package/thttpd/thttpd.conf $(TARGET_DIR)/etc
thttpd: uclibc $(TARGET_DIR)/$(THTTPD_TARGET_BINARY)
thttpd-clean:
rm -f $(TARGET_DIR)/$(THTTPD_TARGET_BINARY)
- rm -f $(TARGET_DIR)/sbin/httpd_wrapper
- rm -f $(TARGET_DIR)/sbin/thttpd_wrapper
rm -rf $(TARGET_DIR)/var/www
- rm -f $(TARGET_DIR)/etc/init.d/S90thttpd
- rm -f $(TARGET_DIR)/bin/htpasswd
- rm -f $(TARGET_DIR)/bin/makeweb
- rm -f $(TARGET_DIR)/bin/syslogtocern
+ rm -f $(TARGET_DIR)/etc/init.d/S90thttpd $(TARGET_DIR)/etc/thttpd.conf
-$(MAKE) -C $(THTTPD_DIR) clean
thttpd-dirclean:
rm -rf $(THTTPD_DIR)
+
#############################################################
#
# Toplevel Makefile options