summaryrefslogtreecommitdiffstats
path: root/package/tcpdump
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/tcpdump
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/tcpdump')
-rw-r--r--package/tcpdump/Makefile.in3
-rw-r--r--package/tcpdump/tcpdump.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/tcpdump/Makefile.in b/package/tcpdump/Makefile.in
deleted file mode 100644
index eb0a85c63..000000000
--- a/package/tcpdump/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_TCPDUMP)),y)
-TARGETS+=tcpdump
-endif
diff --git a/package/tcpdump/tcpdump.mk b/package/tcpdump/tcpdump.mk
index 13d9c44ed..579251582 100644
--- a/package/tcpdump/tcpdump.mk
+++ b/package/tcpdump/tcpdump.mk
@@ -73,3 +73,11 @@ tcpdump-clean:
tcpdump-dirclean:
rm -rf $(TCPDUMP_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_TCPDUMP)),y)
+TARGETS+=tcpdump
+endif