summaryrefslogtreecommitdiffstats
path: root/package/tcpdump
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/tcpdump
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/tcpdump')
-rw-r--r--package/tcpdump/dhcpdump.mk15
-rw-r--r--package/tcpdump/tcpdump.mk20
2 files changed, 26 insertions, 9 deletions
diff --git a/package/tcpdump/dhcpdump.mk b/package/tcpdump/dhcpdump.mk
index 7585b0749..3c6283214 100644
--- a/package/tcpdump/dhcpdump.mk
+++ b/package/tcpdump/dhcpdump.mk
@@ -31,10 +31,19 @@ $(DHCPDUMP_DIR)/.configured: $(DHCPDUMP_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
--with-build-cc="$(HOSTCC)" \
- --prefix=$(STAGING_DIR) \
- --libdir=$(STAGING_DIR)/lib \
- --includedir=$(STAGING_DIR)/include \
)
touch $(DHCPDUMP_DIR)/.configured
diff --git a/package/tcpdump/tcpdump.mk b/package/tcpdump/tcpdump.mk
index 0cadc786f..456e9dc8b 100644
--- a/package/tcpdump/tcpdump.mk
+++ b/package/tcpdump/tcpdump.mk
@@ -32,23 +32,31 @@ $(TCPDUMP_DIR)/.configured: $(TCPDUMP_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
--with-build-cc="$(HOSTCC)" \
- --prefix=$(STAGING_DIR) \
- --libdir=$(STAGING_DIR)/lib \
- --includedir=$(STAGING_DIR)/include \
--without-crypto \
)
$(SED) '/HAVE_PCAP_DEBUG/d' $(TCPDUMP_DIR)/config.h
touch $(TCPDUMP_DIR)/.configured
$(TCPDUMP_DIR)/tcpdump: $(TCPDUMP_DIR)/.configured
- $(MAKE) \
- CC="$(TARGET_CC)" \
+ $(MAKE) CC="$(TARGET_CC)" \
LDFLAGS="-L$(STAGING_DIR)/lib" \
LIBS="-lpcap" \
INCLS="-I. -I$(STAGING_DIR)/include" \
-C $(TCPDUMP_DIR)
-
+
$(TARGET_DIR)/sbin/tcpdump: $(TCPDUMP_DIR)/tcpdump
cp -af $< $@