summaryrefslogtreecommitdiffstats
path: root/package/tcpdump
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-16 21:34:41 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-16 21:34:41 +0000
commit0cd5b3c5f81566ec88f749148ee9fd28827aa006 (patch)
tree1f19ec882716a58ca2408d6d6bf826c3ccb2903b /package/tcpdump
parentcbe260d167497f9b586cee592f024d5299e8e6b3 (diff)
downloadbuildroot-novena-0cd5b3c5f81566ec88f749148ee9fd28827aa006.tar.gz
buildroot-novena-0cd5b3c5f81566ec88f749148ee9fd28827aa006.zip
add dhcpdump
Diffstat (limited to 'package/tcpdump')
-rw-r--r--package/tcpdump/Config.in7
-rw-r--r--package/tcpdump/dhcpdump.mk77
2 files changed, 84 insertions, 0 deletions
diff --git a/package/tcpdump/Config.in b/package/tcpdump/Config.in
index de17e4fa7..5a180a3e2 100644
--- a/package/tcpdump/Config.in
+++ b/package/tcpdump/Config.in
@@ -5,3 +5,10 @@ config BR2_PACKAGE_TCPDUMP
A tool for network monitoring and data acquisition.
http://www.tcpdump.org/
+
+config BR2_PACKAGE_DHCPDUMP
+ bool "dhcpdump"
+ default n
+ depends BR2_PACKAGE_TCPDUMP
+ help
+ A tool for monitoring dhcp requests using tcpdump.
diff --git a/package/tcpdump/dhcpdump.mk b/package/tcpdump/dhcpdump.mk
new file mode 100644
index 000000000..794c5718f
--- /dev/null
+++ b/package/tcpdump/dhcpdump.mk
@@ -0,0 +1,77 @@
+#############################################################
+#
+# dhcpdump
+#
+#############################################################
+# Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
+# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+
+DHCPDUMP_VER:=1.4
+DHCPDUMP_DIR:=$(BUILD_DIR)/dhcpdump-$(DHCPDUMP_VER)
+DHCPDUMP_SITE:=http://www.mavetju.org/download/
+DHCPDUMP_SOURCE:=dhcpdump-$(DHCPDUMP_VER).tar.gz
+DHCPDUMP_CAT:=zcat
+
+$(DL_DIR)/$(DHCPDUMP_SOURCE):
+ $(WGET) -P $(DL_DIR) $(DHCPDUMP_SITE)/$(DHCPDUMP_SOURCE)
+
+dhcpdump-source: $(DL_DIR)/$(DHCPDUMP_SOURCE)
+
+$(DHCPDUMP_DIR)/.unpacked: $(DL_DIR)/$(DHCPDUMP_SOURCE)
+ $(DHCPDUMP_CAT) $(DL_DIR)/$(DHCPDUMP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(DHCPDUMP_DIR)/.unpacked
+
+$(DHCPDUMP_DIR)/.configured: $(DHCPDUMP_DIR)/.unpacked
+ ( \
+ cd $(DHCPDUMP_DIR) ; \
+ BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --with-build-cc=$(HOSTCC) \
+ --prefix=$(STAGING_DIR) \
+ --libdir=$(STAGING_DIR)/lib \
+ --includedir=$(STAGING_DIR)/include \
+ )
+ touch $(DHCPDUMP_DIR)/.configured
+
+$(DHCPDUMP_DIR)/dhcpdump: $(DHCPDUMP_DIR)/.configured
+ $(MAKE) -C $(DHCPDUMP_DIR)
+
+$(TARGET_DIR)/sbin/dhcpdump: $(DHCPDUMP_DIR)/dhcpdump
+ cp -af $< $@
+
+dhcpdump: uclibc zlib libpcap $(TARGET_DIR)/sbin/dhcpdump
+
+dhcpdump-clean:
+ rm -f $(TARGET_DIR)/sbin/dhcpdump
+ -$(MAKE) -C $(DHCPDUMP_DIR) clean
+
+dhcpdump-dirclean:
+ rm -rf $(DHCPDUMP_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_DHCPDUMP)),y)
+TARGETS+=dhcpdump
+endif