summaryrefslogtreecommitdiffstats
path: root/package/taglib
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-04-30 03:48:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-05 23:41:11 +0200
commit5d6f32878f707f4c28fe09d02e960d851c76e3c3 (patch)
treefd1da7d454eb2c305e4e84ab55e2a1451f0857c4 /package/taglib
parent84d589a963d902849b7022091e97ec71c38ed82e (diff)
downloadbuildroot-novena-5d6f32878f707f4c28fe09d02e960d851c76e3c3.tar.gz
buildroot-novena-5d6f32878f707f4c28fe09d02e960d851c76e3c3.zip
package/multimedia: move audio libraries out
Move audio libraries out of the Audio and Video category into the Libraries/Audio one. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/taglib')
-rw-r--r--package/taglib/Config.in22
-rw-r--r--package/taglib/taglib.mk28
2 files changed, 50 insertions, 0 deletions
diff --git a/package/taglib/Config.in b/package/taglib/Config.in
new file mode 100644
index 000000000..d172c34ad
--- /dev/null
+++ b/package/taglib/Config.in
@@ -0,0 +1,22 @@
+
+config BR2_PACKAGE_TAGLIB
+ bool "taglib"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ TagLib is a library for reading and editing the meta-data of
+ several popular audio formats. Currently it supports both ID3v1
+ and ID3v2 for MP3 files, Ogg Vorbis comments and ID3 tags and
+ Vorbis comments in FLAC, MPC, Speex, WavPack and TrueAudio files.
+
+ http://developer.kde.org/~wheeler/taglib.html
+
+config BR2_PACKAGE_TAGLIB_MP4
+ depends on BR2_PACKAGE_TAGLIB
+ bool "taglib mp4 support"
+
+config BR2_PACKAGE_TAGLIB_ASF
+ depends on BR2_PACKAGE_TAGLIB
+ bool "taglib wma support"
+
+comment "taglib requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/taglib/taglib.mk b/package/taglib/taglib.mk
new file mode 100644
index 000000000..da2db0cf2
--- /dev/null
+++ b/package/taglib/taglib.mk
@@ -0,0 +1,28 @@
+#############################################################
+#
+# taglib
+#
+#############################################################
+
+TAGLIB_VERSION = 1.7.1
+TAGLIB_SOURCE = taglib-$(TAGLIB_VERSION).tar.gz
+TAGLIB_SITE = http://developer.kde.org/~wheeler/files/src
+TAGLIB_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PACKAGE_TAGLIB_ASF),y)
+TAGLIB_CONF_OPT += -DWITH_ASF=ON
+endif
+
+ifeq ($(BR2_PACKAGE_TAGLIB_MP4),y)
+TAGLIB_CONF_OPT += -DWITH_MP4=ON
+endif
+
+define TAGLIB_REMOVE_DEVFILE
+ rm -f $(TARGET_DIR)/usr/bin/taglib-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+TAGLIB_POST_INSTALL_TARGET_HOOKS += TAGLIB_REMOVE_DEVFILE
+endif
+
+$(eval $(call CMAKETARGETS))