summaryrefslogtreecommitdiffstats
path: root/package/sysstat
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.landwerlin@openwide.fr>2009-10-18 21:03:09 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-20 23:12:23 +0200
commit0ad5869528742f90791b6a13b94f1fa49c41e809 (patch)
tree954495091e466b722cb25a48ee2f7329bb8a2b56 /package/sysstat
parent7d5d638a892949cd4033d2284a5777e0cb34591b (diff)
downloadbuildroot-novena-0ad5869528742f90791b6a13b94f1fa49c41e809.tar.gz
buildroot-novena-0ad5869528742f90791b6a13b94f1fa49c41e809.zip
package: Add sysstat tools
Signed-off-by: Lionel Landwerlin <lionel.landwerlin@openwide.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sysstat')
-rw-r--r--package/sysstat/Config.in38
-rw-r--r--package/sysstat/sysstat.mk26
2 files changed, 64 insertions, 0 deletions
diff --git a/package/sysstat/Config.in b/package/sysstat/Config.in
new file mode 100644
index 000000000..b084b4186
--- /dev/null
+++ b/package/sysstat/Config.in
@@ -0,0 +1,38 @@
+config BR2_PACKAGE_SYSSTAT
+ bool "sysstat"
+ help
+ The sysstat utilities are a collection of performance
+ monitoring tools for Linux. These include sar, sadf, mpstat,
+ iostat, pidstat and sa tools.
+
+ Some Features :
+
+ * Input / Output and transfer rate statistics (global, per
+ device, per partition, per network filesystem and per
+ Linux task / PID)
+ * CPU statistics (global, per CPU and per Linux task /
+ PID), including support for virtualization architectures
+ * Memory and swap space utilization statistics
+ * Virtual memory, paging and fault statistics
+ * Per-task (per-PID) memory and page fault statistics
+ * Global CPU and page fault statistics for tasks and all
+ their children
+ * Process creation activity
+ * Interrupt statistics (global, per CPU and per interrupt,
+ including potential APIC interrupt sources)
+ * Extensive network statistics: network interface activity
+ (number of packets and kB received and transmitted per
+ second, etc.) including failures from network devices;
+ network traffic statistics for IP, TCP, ICMP and UDP
+ protocols based on SNMPv2 standards; support for
+ IPv6-related protocols.
+ * NFS server and client activity
+ * Socket statistics
+ * Run queue and system load statistics
+ * Kernel internal tables utilization statistics
+ * System and per Linux task switching activity
+ * Swapping statistics
+ * TTY device activity
+ * Power management statistics
+
+ http://pagesperso-orange.fr/sebastien.godard/
diff --git a/package/sysstat/sysstat.mk b/package/sysstat/sysstat.mk
new file mode 100644
index 000000000..324580eda
--- /dev/null
+++ b/package/sysstat/sysstat.mk
@@ -0,0 +1,26 @@
+#############################################################
+#
+# sysstat
+#
+#############################################################
+
+SYSSTAT_VERSION = 9.0.5
+SYSSTAT_SOURCE = sysstat-$(SYSSTAT_VERSION).tar.bz2
+SYSSTAT_SITE = http://pagesperso-orange.fr/sebastien.godard/
+SYSSTAT_AUTORECONF = NO
+SYSSTAT_LIBTOOL_PATCH = NO
+SYSSTAT_INSTALL_STAGING = NO
+SYSSTAT_INSTALL_TARGET = YES
+
+# Should be --disable-man-group, it might be a little mistake in the
+# configure.in script.
+SYSSTAT_CONF_OPT = --enable-man-group
+ifneq ($(BR2_HAVE_DOCUMENTATION),y)
+SYSSTAT_CONF_OPT += --disable-documentation
+endif
+
+# The isag tool is a post processing script that depends on tcl/tk
+# among other things. So we don't install it.
+SYSSTAT_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) INSTALL_ISAG=n install
+
+$(eval $(call AUTOTARGETS,package,sysstat))