summaryrefslogtreecommitdiffstats
path: root/package/synergy
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-02-24 09:43:52 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-24 09:43:52 +0100
commitc9253253c1cb80fb8574c3d313a129b64b4ad2a1 (patch)
tree4f70a13eef59c3a7346760bf47dd29cd62926eac /package/synergy
parentfd2bd9e3df276301f867b05bd9f47ab3ab7b4ef4 (diff)
downloadbuildroot-novena-c9253253c1cb80fb8574c3d313a129b64b4ad2a1.tar.gz
buildroot-novena-c9253253c1cb80fb8574c3d313a129b64b4ad2a1.zip
synergy: fix build
Closes #3307 Synergy needs libXtst, a toolchain with wchar support and was missing an include for exit(). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/synergy')
-rw-r--r--package/synergy/Config.in6
-rw-r--r--package/synergy/synergy-1.3.1-exit.patch21
-rw-r--r--package/synergy/synergy.mk2
3 files changed, 26 insertions, 3 deletions
diff --git a/package/synergy/Config.in b/package/synergy/Config.in
index a2766b13e..7d8c54ece 100644
--- a/package/synergy/Config.in
+++ b/package/synergy/Config.in
@@ -2,6 +2,8 @@ config BR2_PACKAGE_SYNERGY
bool "synergy"
depends on BR2_PACKAGE_XORG7
depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_WCHAR
+ select BR2_PACKAGE_XLIB_LIBXTST
help
Synergy lets you easily share a single mouse and
keyboard between multiple computers with different
@@ -10,5 +12,5 @@ config BR2_PACKAGE_SYNERGY
http://synergy2.sourceforge.net/
-comment "synergy requires a toolchain with C++ support enabled"
- depends on BR2_PACKAGE_XORG7 && !BR2_INSTALL_LIBSTDCPP
+comment "synergy requires a toolchain with C++ and WCHAR support enabled"
+ depends on BR2_PACKAGE_XORG7 && !BR2_INSTALL_LIBSTDCPP && !BR2_USE_WCHAR
diff --git a/package/synergy/synergy-1.3.1-exit.patch b/package/synergy/synergy-1.3.1-exit.patch
new file mode 100644
index 000000000..1eb665f55
--- /dev/null
+++ b/package/synergy/synergy-1.3.1-exit.patch
@@ -0,0 +1,21 @@
+[PATCH] fix build issue in CArchDaemonUnix
+
+exit() needs #include <stdlib.h> for the prototype.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ lib/arch/CArchDaemonUnix.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
+===================================================================
+--- synergy-1.3.1.orig/lib/arch/CArchDaemonUnix.cpp
++++ synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
+@@ -19,6 +19,7 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <stdlib.h>
+
+ //
+ // CArchDaemonUnix
diff --git a/package/synergy/synergy.mk b/package/synergy/synergy.mk
index f70806d25..ce3f2141a 100644
--- a/package/synergy/synergy.mk
+++ b/package/synergy/synergy.mk
@@ -11,6 +11,6 @@ SYNERGY_AUTORECONF = NO
SYNERGY_INSTALL_STAGING = NO
SYNERGY_INSTALL_TARGET = YES
-SYNERGY_DEPENDENCIES = xserver_xorg-server
+SYNERGY_DEPENDENCIES = xserver_xorg-server xlib_libXtst
$(eval $(call AUTOTARGETS,package,synergy))