summaryrefslogtreecommitdiffstats
path: root/package/stunnel/stunnel.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-08-29 22:04:02 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-08-29 22:04:02 +0200
commit6c5193878189d9d199f3d88df52406a375f3e51e (patch)
tree1d6b772fe01cf3fdcc247b9be4003dc796136ce4 /package/stunnel/stunnel.mk
parent6ef440ba0d1a0754c07db26ddb77ab81a0d401de (diff)
downloadbuildroot-novena-6c5193878189d9d199f3d88df52406a375f3e51e.tar.gz
buildroot-novena-6c5193878189d9d199f3d88df52406a375f3e51e.zip
stunnel: remove broken package
It doesn't build as there's no dependency on openssl, and it hasn't seen any real updates since it got added in 2006, so simply remove it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/stunnel/stunnel.mk')
-rw-r--r--package/stunnel/stunnel.mk82
1 files changed, 0 insertions, 82 deletions
diff --git a/package/stunnel/stunnel.mk b/package/stunnel/stunnel.mk
deleted file mode 100644
index 834ef9629..000000000
--- a/package/stunnel/stunnel.mk
+++ /dev/null
@@ -1,82 +0,0 @@
-#############################################################
-#
-# stunnel
-#
-#############################################################
-STUNNEL_VERSION:=4.16
-STUNNEL_SOURCE:=stunnel-$(STUNNEL_VERSION).tar.gz
-STUNNEL_SITE:=http://www.stunnel.org/download/stunnel/src
-STUNNEL_CAT:=$(ZCAT)
-STUNNEL_DIR:=$(BUILD_DIR)/stunnel-$(STUNNEL_VERSION)
-
-$(DL_DIR)/$(STUNNEL_SOURCE):
- $(call DOWNLOAD,$(STUNNEL_SITE),$(STUNNEL_SOURCE))
-
-stunnel-source: $(DL_DIR)/$(STUNNEL_SOURCE)
-
-$(STUNNEL_DIR)/.unpacked: $(DL_DIR)/$(STUNNEL_SOURCE)
- $(STUNNEL_CAT) $(DL_DIR)/$(STUNNEL_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- $(CONFIG_UPDATE) $(STUNNEL_DIR)
- toolchain/patch-kernel.sh $(STUNNEL_DIR) package/stunnel stunnel\*.patch
- touch $(STUNNEL_DIR)/*
- touch $(STUNNEL_DIR)/.unpacked
-
-$(STUNNEL_DIR)/.configured: $(STUNNEL_DIR)/.unpacked
- (cd $(STUNNEL_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- $(TARGET_CONFIGURE_ARGS) \
- ac_cv_file___dev_ptmx_=yes \
- ac_cv_file___dev_ptc_=no \
- ./configure $(QUIET) \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libdir=/lib \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --with-random=/dev/urandom \
- --disable-libwrap \
- --with-ssl=$(STAGING_DIR)/usr/ \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- )
- touch $(STUNNEL_DIR)/.configured
-
-$(STUNNEL_DIR)/src/stunnel: $(STUNNEL_DIR)/.configured
- $(MAKE) CC="$(TARGET_CC)" -C $(STUNNEL_DIR)
-
-$(TARGET_DIR)/usr/bin/stunnel: $(STUNNEL_DIR)/src/stunnel
- install -c $(STUNNEL_DIR)/src/stunnel $(TARGET_DIR)/usr/bin/stunnel
- $(STRIPCMD) $(TARGET_DIR)/usr/bin/stunnel > /dev/null 2>&1
-ifeq ($(BR2_CROSS_TOOLCHAIN_TARGET_UTILS),y)
- mkdir -p $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils
- install -c $(TARGET_DIR)/usr/bin/stunnel \
- $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils/stunnel
-endif
-
-stunnel: $(TARGET_DIR)/usr/bin/stunnel
-
-stunnel-clean:
- -$(MAKE) -C $(STUNNEL_DIR) clean
- rm -f $(TARGET_DIR)/usr/bin/stunnel
-
-stunnel-dirclean:
- rm -rf $(STUNNEL_DIR)
-
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_STUNNEL),y)
-TARGETS+=stunnel
-endif