summaryrefslogtreecommitdiffstats
path: root/package/stress
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-05-04 11:32:56 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-05 08:40:06 +0200
commita90617b6271c86769a03ea8f7cfc5a58451e02c5 (patch)
tree7bc862930904374518ad0d1c93a7228e7e9bdd51 /package/stress
parent4205dbd9f665556cc56a36c0e11a5f845c73a57a (diff)
downloadbuildroot-novena-a90617b6271c86769a03ea8f7cfc5a58451e02c5.tar.gz
buildroot-novena-a90617b6271c86769a03ea8f7cfc5a58451e02c5.zip
stress: new package
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/stress')
-rw-r--r--package/stress/Config.in8
-rw-r--r--package/stress/stress-0001-Remove-largefile.patch22
-rw-r--r--package/stress/stress.mk13
3 files changed, 43 insertions, 0 deletions
diff --git a/package/stress/Config.in b/package/stress/Config.in
new file mode 100644
index 000000000..b092b03a8
--- /dev/null
+++ b/package/stress/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_STRESS
+ bool "stress"
+ help
+ A deliberately simple workload generator for POSIX systems.
+ It imposes a configurable amount of CPU, memory, I/O, and
+ disk stress on the system.
+
+ http://weather.ou.edu/~apw/projects/stress/
diff --git a/package/stress/stress-0001-Remove-largefile.patch b/package/stress/stress-0001-Remove-largefile.patch
new file mode 100644
index 000000000..bf894bc05
--- /dev/null
+++ b/package/stress/stress-0001-Remove-largefile.patch
@@ -0,0 +1,22 @@
+Remove largefile
+
+Otherwise it doesn't compile in uClibc without largefile.
+
+If the toolchain does support largefile, it will still work on large files
+anyway.
+
+Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
+---
+Upstream status: mail sent to apw@rossby.metr.ou.edu
+---
+diff -rup stress-1.0.4.orig/src/Makefile.am stress-1.0.4/src/Makefile.am
+--- stress-1.0.4.orig/src/Makefile.am 2009-12-03 02:04:05.000000000 +0100
++++ stress-1.0.4/src/Makefile.am 2012-05-04 23:09:48.229842463 +0200
+@@ -1,7 +1,5 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+-AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+-
+ bin_PROGRAMS = stress
+ stress_SOURCES = stress.c
+ stress_MANS = stress.1
diff --git a/package/stress/stress.mk b/package/stress/stress.mk
new file mode 100644
index 000000000..8b4f40bd3
--- /dev/null
+++ b/package/stress/stress.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# stress - a workload generator
+#
+# http://weather.ou.edu/~apw/projects/stress/
+#
+#############################################################
+
+STRESS_VERSION = 1.0.4
+STRESS_SITE = http://weather.ou.edu/~apw/projects/stress
+STRESS_AUTORECONF = YES
+
+$(eval $(call AUTOTARGETS))