summaryrefslogtreecommitdiffstats
path: root/package/sqlite
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2011-12-07 20:00:09 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-11 22:16:16 +0100
commitd2e7ec721f28a360b6bda2ed7e0f26218accc292 (patch)
treecb7ab9988916634b711306f44a29bf79e4e6c7e5 /package/sqlite
parentc0e8772a7fba6a4f7d010bdd1ffe39e12f42f3f2 (diff)
downloadbuildroot-novena-d2e7ec721f28a360b6bda2ed7e0f26218accc292.tar.gz
buildroot-novena-d2e7ec721f28a360b6bda2ed7e0f26218accc292.zip
sqlite: refactor how CFLAGS are passed to the configure script
Change the way the SQLITE_CONF_ENV variable is constructed in preparation of passing other CFLAGS to the configure script. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sqlite')
-rw-r--r--package/sqlite/sqlite.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index f587f4770..0bee337e7 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -13,9 +13,11 @@ ifneq ($(BR2_LARGEFILE),y)
# the sqlite configure script fails to define SQLITE_DISABLE_LFS when
# --disable-largefile is passed, breaking the build. Work around it by
# simply adding it to CFLAGS for configure instead
-SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DSQLITE_DISABLE_LFS"
+SQLITE_CFLAGS += -DSQLITE_DISABLE_LFS
endif
+SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) $(SQLITE_CFLAGS)"
+
SQLITE_CONF_OPT = \
--enable-threadsafe \
--localstatedir=/var