summaryrefslogtreecommitdiffstats
path: root/package/sqlite
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-18 09:48:24 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-18 09:48:24 +0200
commit856ba320975740542bc4525efabc3cb63f76869f (patch)
tree9615ab8574e7d5bb029fb17f5b2413372d009627 /package/sqlite
parentadbe85c752651bc147bc4deb6419d162b2c6417e (diff)
downloadbuildroot-novena-856ba320975740542bc4525efabc3cb63f76869f.tar.gz
buildroot-novena-856ba320975740542bc4525efabc3cb63f76869f.zip
sqlite: do not assume thread support is available
The --enable-threadsafe option was unconditionally passed, without taking into account whether the underlying toolchain had thread support or not. Now, we properly pass --enable-threadsafe or --disable-threadsafe depending on the availability of thread support. Fixes http://autobuild.buildroot.net/results/defdc098cff293baabf2f89587476eba71f1c0d0/build-end.log. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sqlite')
-rw-r--r--package/sqlite/sqlite.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index 5b85ecc5f..9e63b521d 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -23,9 +23,14 @@ endif
SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) $(SQLITE_CFLAGS)"
SQLITE_CONF_OPT = \
- --enable-threadsafe \
--localstatedir=/var
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+SQLITE_CONF_OPT += --enable-threadsafe
+else
+SQLITE_CONF_OPT += --disable-threadsafe
+endif
+
ifeq ($(BR2_PACKAGE_SQLITE_READLINE),y)
SQLITE_DEPENDENCIES += ncurses readline
SQLITE_CONF_OPT += --with-readline-inc="-I$(STAGING_DIR)/usr/include"