summaryrefslogtreecommitdiffstats
path: root/package/sqlite
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/sqlite
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/sqlite')
-rw-r--r--package/sqlite/sqlite.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index 254abbd5e..8946577d4 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -30,7 +30,17 @@ $(SQLITE_DIR)/.configured: $(SQLITE_DIR)/.unpacked
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
--sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
--enable-shared \
--enable-static \
--disable-tcl \
@@ -44,7 +54,7 @@ $(SQLITE_DIR)/sqlite3: $(SQLITE_DIR)/.configured
$(MAKE) -C $(SQLITE_DIR)
$(STAGING_DIR)/bin/sqlite3: $(SQLITE_DIR)/sqlite3
- $(MAKE) prefix=$(STAGING_DIR) -C $(SQLITE_DIR) install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SQLITE_DIR) install
$(TARGET_DIR)/usr/bin/sqlite3: $(STAGING_DIR)/bin/sqlite3
cp -a $(STAGING_DIR)/bin/sqlite3 $(TARGET_DIR)/usr/bin