summaryrefslogtreecommitdiffstats
path: root/package/sqlite
diff options
context:
space:
mode:
authorChris Zankel <chris@zankel.net>2013-01-22 10:33:19 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-30 00:19:42 +0100
commit6a30cd3fb30b8057ddde2c72a88c0bb6ad7d1761 (patch)
tree6d075195da8959103b66468f29588966ae17b4f6 /package/sqlite
parentbf885f10b798ef5b2e687c7f8171034bae6e3888 (diff)
downloadbuildroot-novena-6a30cd3fb30b8057ddde2c72a88c0bb6ad7d1761.tar.gz
buildroot-novena-6a30cd3fb30b8057ddde2c72a88c0bb6ad7d1761.zip
xtensa: sqlite requires special compiler option
Some of the generated object files are too large for PC-relative addressing, so use the -mtext-section-literals compiler flag to move symbols closer to the code. [Peter: fix commit message] Signed-off-by: Chris Zankel <chris@zankel.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sqlite')
-rw-r--r--package/sqlite/sqlite.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index bf4b92124..8eb6b2f76 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -33,6 +33,10 @@ ifeq ($(BR2_PACKAGE_SQLITE_SECURE_DELETE),y)
SQLITE_CFLAGS += -DSQLITE_SECURE_DELETE
endif
+ifeq ($(BR2_xtensa),y)
+SQLITE_CFLAGS += -mtext-section-literals
+endif
+
SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) $(SQLITE_CFLAGS)"
SQLITE_CONF_OPT = \