summaryrefslogtreecommitdiffstats
path: root/package/sqlite
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-05-28 02:17:32 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-28 23:26:58 +0200
commit316f991729c423c9a49a955d3747ff31ad7a0068 (patch)
tree6fa09107ef626d8042b37df5a73937f935e2a29a /package/sqlite
parent5a85d57f24bf42adea4b7d4431866709f6534df4 (diff)
downloadbuildroot-novena-316f991729c423c9a49a955d3747ff31ad7a0068.tar.gz
buildroot-novena-316f991729c423c9a49a955d3747ff31ad7a0068.zip
sqlite: bump to version 3.7.17
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sqlite')
-rw-r--r--package/sqlite/sqlite-dont-force-posix-fallocate.patch23
-rw-r--r--package/sqlite/sqlite.mk4
2 files changed, 25 insertions, 2 deletions
diff --git a/package/sqlite/sqlite-dont-force-posix-fallocate.patch b/package/sqlite/sqlite-dont-force-posix-fallocate.patch
new file mode 100644
index 000000000..118001bfd
--- /dev/null
+++ b/package/sqlite/sqlite-dont-force-posix-fallocate.patch
@@ -0,0 +1,23 @@
+This is checked by configure and passed as a define directive when building.
+There's no need to check again and potentially override a failed check
+(uClibc <= 0.9.33.2 for example lacks posix_fallocate).
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura sqlite-autoconf-3071700.orig/sqlite3.c sqlite-autoconf-3071700/sqlite3.c
+--- sqlite-autoconf-3071700.orig/sqlite3.c 2013-05-23 03:17:27.170459400 -0300
++++ sqlite-autoconf-3071700/sqlite3.c 2013-05-23 03:25:01.839227616 -0300
+@@ -22931,13 +22931,6 @@
+ */
+ #if SQLITE_OS_UNIX /* This file is used on unix only */
+
+-/* Use posix_fallocate() if it is available
+-*/
+-#if !defined(HAVE_POSIX_FALLOCATE) \
+- && (_XOPEN_SOURCE >= 600 || _POSIX_C_SOURCE >= 200112L)
+-# define HAVE_POSIX_FALLOCATE 1
+-#endif
+-
+ /*
+ ** There are various methods for file locking used for concurrency
+ ** control:
diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index 8eb6b2f76..39a39d0c5 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -4,9 +4,9 @@
#
#############################################################
-SQLITE_VERSION = 3071401
+SQLITE_VERSION = 3071700
SQLITE_SOURCE = sqlite-autoconf-$(SQLITE_VERSION).tar.gz
-SQLITE_SITE = http://www.sqlite.org
+SQLITE_SITE = http://www.sqlite.org/2013
SQLITE_LICENSE = Public domain
SQLITE_INSTALL_STAGING = YES