summaryrefslogtreecommitdiffstats
path: root/package/spice
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-16 06:56:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 21:35:27 +0100
commit5faf337b39a0515439b828c5ad12858fa9c02b38 (patch)
tree27b3fdf47505656966b1fe6666cc0384ef8973a0 /package/spice
parentaf103acf4eb7fa6193c0bb9d844ea95f4e15db71 (diff)
downloadbuildroot-novena-5faf337b39a0515439b828c5ad12858fa9c02b38.tar.gz
buildroot-novena-5faf337b39a0515439b828c5ad12858fa9c02b38.zip
package/spice: enable slirp support
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/spice')
-rw-r--r--package/spice/Config.in7
-rw-r--r--package/spice/spice.mk8
2 files changed, 14 insertions, 1 deletions
diff --git a/package/spice/Config.in b/package/spice/Config.in
index 08c3893f6..b1e187a63 100644
--- a/package/spice/Config.in
+++ b/package/spice/Config.in
@@ -41,4 +41,11 @@ config BR2_PACKAGE_SPICE_GUI
Say 'y' here to enable the Graphical User Interface (GUI)
start dialog.
+config BR2_PACKAGE_SPICE_TUNNEL
+ bool "Enable network redirection"
+ select BR2_PACKAGE_SLIRP
+ help
+ Say 'y' here to enable network redirection, aka tunnelling
+ through a SLIP/SLIRP session.
+
endif # BR2_PACKAGE_SPICE
diff --git a/package/spice/spice.mk b/package/spice/spice.mk
index 0a5c58e17..78ca202b1 100644
--- a/package/spice/spice.mk
+++ b/package/spice/spice.mk
@@ -22,7 +22,6 @@ SPICE_DEPENDENCIES = \
# We disable everything for now, because the dependency tree can become
# quite deep if we try to enable some features, and I have not tested that.
SPICE_CONF_OPT = \
- --disable-tunnel \
--disable-opengl \
--disable-smartcard \
--disable-automated-tests \
@@ -44,6 +43,13 @@ else
SPICE_CONF_OPT += --disable-gui
endif
+ifeq ($(BR2_PACKAGE_SPICE_TUNNEL),y)
+SPICE_CONF_OPT += --enable-tunnel
+SPICE_DEPENDENCIES += slirp
+else
+SPICE_CONF_OPT += --disable-tunnel
+endif
+
SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages