summaryrefslogtreecommitdiffstats
path: root/package/speex
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-04-30 03:48:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-05 23:41:11 +0200
commit5d6f32878f707f4c28fe09d02e960d851c76e3c3 (patch)
treefd1da7d454eb2c305e4e84ab55e2a1451f0857c4 /package/speex
parent84d589a963d902849b7022091e97ec71c38ed82e (diff)
downloadbuildroot-novena-5d6f32878f707f4c28fe09d02e960d851c76e3c3.tar.gz
buildroot-novena-5d6f32878f707f4c28fe09d02e960d851c76e3c3.zip
package/multimedia: move audio libraries out
Move audio libraries out of the Audio and Video category into the Libraries/Audio one. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/speex')
-rw-r--r--package/speex/Config.in25
-rw-r--r--package/speex/speex.mk34
2 files changed, 59 insertions, 0 deletions
diff --git a/package/speex/Config.in b/package/speex/Config.in
new file mode 100644
index 000000000..424a83001
--- /dev/null
+++ b/package/speex/Config.in
@@ -0,0 +1,25 @@
+config BR2_PACKAGE_SPEEX
+ bool "speex"
+ select BR2_PACKAGE_LIBOGG
+ help
+ Speex is an Open Source/Free Software patent-free
+ audio compression format designed for speech.
+ It can be used for Voice over IP
+
+ http://www.speex.org/
+
+config BR2_PACKAGE_SPEEX_ARM_GENERIC
+ bool
+ default y
+ depends on BR2_PACKAGE_SPEEX && (BR2_generic_arm || BR2_arm610 || BR2_arm710)
+
+config BR2_PACKAGE_SPEEX_ARM4
+ bool
+ default y
+ depends on BR2_PACKAGE_SPEEX && (BR2_arm7tdmi || BR2_arm720t || BR2_arm920t || BR2_arm922t || BR2_sa110 || BR2_sa1100)
+
+config BR2_PACKAGE_SPEEX_ARM5E
+ default y
+ bool
+ depends on BR2_PACKAGE_SPEEX && BR2_arm && !(BR2_PACKAGE_SPEEX_ARM_GENERIC || BR2_PACKAGE_SPEEX_ARM4)
+
diff --git a/package/speex/speex.mk b/package/speex/speex.mk
new file mode 100644
index 000000000..c9d9ed3ef
--- /dev/null
+++ b/package/speex/speex.mk
@@ -0,0 +1,34 @@
+#############################################################
+#
+# speex
+#
+#############################################################
+SPEEX_VERSION=1.2rc1
+SPEEX_SOURCE=speex-$(SPEEX_VERSION).tar.gz
+SPEEX_SITE=http://downloads.us.xiph.org/releases/speex
+SPEEX_INSTALL_STAGING = YES
+SPEEX_DEPENDENCIES = libogg
+SPEEX_CONF_OPT = --with-ogg-libraries=$(STAGING_DIR)/usr/lib \
+ --with-ogg-includes=$(STAGING_DIR)/usr/include \
+ --enable-fixed-point
+
+ifeq ($(BR2_PACKAGE_SPEEX_ARM4),y)
+ SPEEX_CONF_OPT += --enable-arm4-asm
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX_ARM5E),y)
+ SPEEX_CONF_OPT += --enable-arm5e-asm
+endif
+
+define SPEEX_LIBTOOL_FIXUP
+ $(SED) 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' $(@D)/libtool
+ $(SED) 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' $(@D)/libtool
+endef
+
+SPEEX_POST_CONFIGURE_HOOKS += SPEEX_LIBTOOL_FIXUP
+
+define SPEEX_BUILD_CMDS
+ $($(PKG)_MAKE_ENV) $(MAKE) $($(PKG)_MAKE_OPT) -C $(@D)/$($(PKG)_SUBDIR)
+endef
+
+$(eval $(call AUTOTARGETS))