summaryrefslogtreecommitdiffstats
path: root/package/speex
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-08-17 13:46:42 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-08-17 13:46:42 +0000
commit46d6d83273e47872cf41b314a9c1c4d01ff42056 (patch)
tree395f304b49c863153df72feb41f60b9132e002e0 /package/speex
parent28b2a5bd7e504d458e72788cecaa6e57ba89d4de (diff)
downloadbuildroot-novena-46d6d83273e47872cf41b314a9c1c4d01ff42056.tar.gz
buildroot-novena-46d6d83273e47872cf41b314a9c1c4d01ff42056.zip
speex: automate selection of arm specific optimizations
ARM version info according to wikipedia, hopefully I got it all correct.
Diffstat (limited to 'package/speex')
-rw-r--r--package/speex/Config.in18
-rw-r--r--package/speex/speex.mk4
2 files changed, 17 insertions, 5 deletions
diff --git a/package/speex/Config.in b/package/speex/Config.in
index 5b0b925eb..424a83001 100644
--- a/package/speex/Config.in
+++ b/package/speex/Config.in
@@ -8,10 +8,18 @@ config BR2_PACKAGE_SPEEX
http://www.speex.org/
+config BR2_PACKAGE_SPEEX_ARM_GENERIC
+ bool
+ default y
+ depends on BR2_PACKAGE_SPEEX && (BR2_generic_arm || BR2_arm610 || BR2_arm710)
+
+config BR2_PACKAGE_SPEEX_ARM4
+ bool
+ default y
+ depends on BR2_PACKAGE_SPEEX && (BR2_arm7tdmi || BR2_arm720t || BR2_arm920t || BR2_arm922t || BR2_sa110 || BR2_sa1100)
+
config BR2_PACKAGE_SPEEX_ARM5E
- bool "Support ARM5E instruction set"
default y
- depends on BR2_PACKAGE_SPEEX && BR2_arm
- help
- Use the additional instructions available in the ARM5E
- or later cores.
+ bool
+ depends on BR2_PACKAGE_SPEEX && BR2_arm && !(BR2_PACKAGE_SPEEX_ARM_GENERIC || BR2_PACKAGE_SPEEX_ARM4)
+
diff --git a/package/speex/speex.mk b/package/speex/speex.mk
index 4aabe8bc6..51d382fa3 100644
--- a/package/speex/speex.mk
+++ b/package/speex/speex.mk
@@ -14,6 +14,10 @@ SPEEX_DEPENDENCIES = libogg
SPEEX_CONF_OPT = --with-ogg-libraries=$(STAGING_DIR)/usr/lib --with-ogg-includes=$(STAGING_DIR)/usr/include \
--disable-static --enable-fixed-point $(DISABLE_NLS)
+ifeq ($(BR2_PACKAGE_SPEEX_ARM4),y)
+ SPEEX_CONF_OPT += --enable-arm4-asm
+endif
+
ifeq ($(BR2_PACKAGE_SPEEX_ARM5E),y)
SPEEX_CONF_OPT += --enable-arm5e-asm
endif