summaryrefslogtreecommitdiffstats
path: root/package/sound-theme-borealis
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-07-20 10:20:03 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-20 21:08:53 +0200
commit594610a39ed94fb6bf9c5b6b9b52580c82944635 (patch)
treebc815411edea309b9e5293051ce5986d1e18cff9 /package/sound-theme-borealis
parent45166f30dc40ce810831657c27724a3b5a57f2ad (diff)
downloadbuildroot-novena-594610a39ed94fb6bf9c5b6b9b52580c82944635.tar.gz
buildroot-novena-594610a39ed94fb6bf9c5b6b9b52580c82944635.zip
sound-theme-borealis: new package
[thomas.petazzoni@free-electrons.com: slightly adjust the installation process to just do a loop of calls to $(INSTALL).] Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sound-theme-borealis')
-rw-r--r--package/sound-theme-borealis/Config.in6
-rw-r--r--package/sound-theme-borealis/sound-theme-borealis.mk21
2 files changed, 27 insertions, 0 deletions
diff --git a/package/sound-theme-borealis/Config.in b/package/sound-theme-borealis/Config.in
new file mode 100644
index 000000000..fcc109fe9
--- /dev/null
+++ b/package/sound-theme-borealis/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_SOUND_THEME_BOREALIS
+ bool "sound-theme-borealis"
+ help
+ Borealis sound theme.
+
+ http://kde-look.org/content/show.php?content=12584
diff --git a/package/sound-theme-borealis/sound-theme-borealis.mk b/package/sound-theme-borealis/sound-theme-borealis.mk
new file mode 100644
index 000000000..afca72a10
--- /dev/null
+++ b/package/sound-theme-borealis/sound-theme-borealis.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# sound-theme-borealis
+#
+#############################################################
+SOUND_THEME_BOREALIS_VERSION = 0.9a
+SOUND_THEME_BOREALIS_SITE = http://ico.bukvic.net/Linux/Borealis_soundtheme
+SOUND_THEME_BOREALIS_SOURCE = \
+ Borealis_sound_theme_ogg-$(SOUND_THEME_BOREALIS_VERSION).tar.bz2
+
+define SOUND_THEME_BOREALIS_INSTALL_TARGET_CMDS
+ for f in $(@D)/*.ogg ; do \
+ $(INSTALL) -D -m 0644 $$f $(TARGET_DIR)/usr/share/sounds/borealis/stereo/`basename $$f` ; \
+ done
+endef
+
+define SOUND_THEME_BOREALIS_UNINSTALL_TARGET_CMDS
+ $(RM) -r $(TARGET_DIR)/usr/share/sounds/borealis
+endef
+
+$(eval $(generic-package))