summaryrefslogtreecommitdiffstats
path: root/package/socat
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/socat
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
downloadbuildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-novena-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/socat')
-rw-r--r--package/socat/Makefile.in3
-rw-r--r--package/socat/socat.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/socat/Makefile.in b/package/socat/Makefile.in
deleted file mode 100644
index 25df8b42a..000000000
--- a/package/socat/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_SOCAT)),y)
-TARGETS+=socat
-endif
diff --git a/package/socat/socat.mk b/package/socat/socat.mk
index 37df0e7c7..5dd22ccd5 100644
--- a/package/socat/socat.mk
+++ b/package/socat/socat.mk
@@ -67,3 +67,11 @@ socat-clean:
socat-dirclean:
rm -rf $(SOCAT_DIR) $(SOCAT_WORKDIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_SOCAT)),y)
+TARGETS+=socat
+endif