summaryrefslogtreecommitdiffstats
path: root/package/snowball-init
diff options
context:
space:
mode:
authorGregory Hermant <gregory.hermant@calao-systems.com>2012-11-30 02:39:14 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 08:00:55 -0800
commit4d4b1e4c5d98cbaafb8473c29d06b0d472cb34df (patch)
tree9a0283d208573f60711ccc85a92c78634a368efb /package/snowball-init
parent4052e3325c240034e24cbb1b445adf32320baa98 (diff)
downloadbuildroot-novena-4d4b1e4c5d98cbaafb8473c29d06b0d472cb34df.tar.gz
buildroot-novena-4d4b1e4c5d98cbaafb8473c29d06b0d472cb34df.zip
Add init script files for snowball board
Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/snowball-init')
-rw-r--r--package/snowball-init/Config.in14
-rw-r--r--package/snowball-init/snowball-init.mk15
2 files changed, 29 insertions, 0 deletions
diff --git a/package/snowball-init/Config.in b/package/snowball-init/Config.in
new file mode 100644
index 000000000..99abb350f
--- /dev/null
+++ b/package/snowball-init/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_SNOWBALL_INIT
+ bool "snowball-init"
+ # Runtime dependency, needed by snowball startup script
+ select BR2_PACKAGE_BLUEZ_UTILS
+ depends on !BR2_avr32
+ depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, alsa-lib
+ depends on BR2_USE_MMU # dbus
+ select BR2_PACKAGE_UX500_FIRMWARE
+ help
+ Snowball init scripts
+
+ http://www.igloocommunity.org
+
diff --git a/package/snowball-init/snowball-init.mk b/package/snowball-init/snowball-init.mk
new file mode 100644
index 000000000..278cacb2c
--- /dev/null
+++ b/package/snowball-init/snowball-init.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# snowball-init
+#
+#############################################################
+SNOWBALL_INIT_VERSION = b064be21de25729039e5e54037bbdd2e25cfd5b7
+SNOWBALL_INIT_SITE = git://igloocommunity.org/git/bsp/snowball-init.git
+SNOWBALL_INIT_LICENSE = BSD-4c
+SNOWBALL_INIT_LICENSE_FILES = debian/copyright
+
+define SNOWBALL_INIT_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/snowball $(TARGET_DIR)/etc/init.d/S50snowball
+endef
+
+$(eval $(generic-package))