summaryrefslogtreecommitdiffstats
path: root/package/snowball-hdmiservice
diff options
context:
space:
mode:
authorGregory Hermant <gregory.hermant@calao-systems.com>2012-11-30 02:39:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 07:58:22 -0800
commit7e9f8ad164e4776ff89e0f7d674e77032a472d54 (patch)
tree63b2842378f90823d15f0d37834b0758acb978cd /package/snowball-hdmiservice
parentfc50f0c372d8c49dc713b11e756c1d940163b496 (diff)
downloadbuildroot-novena-7e9f8ad164e4776ff89e0f7d674e77032a472d54.tar.gz
buildroot-novena-7e9f8ad164e4776ff89e0f7d674e77032a472d54.zip
snowball-hdmiservice: new package
Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> (on various archs and toolchains) Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/snowball-hdmiservice')
-rw-r--r--package/snowball-hdmiservice/Config.in10
-rw-r--r--package/snowball-hdmiservice/snowball-hdmiservice.mk41
2 files changed, 51 insertions, 0 deletions
diff --git a/package/snowball-hdmiservice/Config.in b/package/snowball-hdmiservice/Config.in
new file mode 100644
index 000000000..0ea7c8120
--- /dev/null
+++ b/package/snowball-hdmiservice/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_SNOWBALL_HDMISERVICE
+ bool "snowball-hdmiservice"
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ HDMI userspace control daemon
+
+ This package contains the HDMI userspace control daemon for the
+ snowball board
+
+ http://www.igloocommunity.org
diff --git a/package/snowball-hdmiservice/snowball-hdmiservice.mk b/package/snowball-hdmiservice/snowball-hdmiservice.mk
new file mode 100644
index 000000000..ebd65dfba
--- /dev/null
+++ b/package/snowball-hdmiservice/snowball-hdmiservice.mk
@@ -0,0 +1,41 @@
+#############################################################
+#
+# snowball-hdmiservice
+#
+#############################################################
+SNOWBALL_HDMISERVICE_VERSION = f75c99d1c52707240a78b4ba78e41d20d3aa3b08
+SNOWBALL_HDMISERVICE_SITE = git://igloocommunity.org/git/bsp/hdmiservice.git
+SNOWBALL_HDMISERVICE_LICENSE = MIT
+SNOWBALL_HDMISERVICE_LICENSE_FILES = debian/copyright
+SNOWBALL_HDMISERVICE_INSTALL_STAGING = YES
+
+define SNOWBALL_HDMISERVICE_BUILD_CMDS
+ $(MAKE) -C $(@D) CC="$(TARGET_CC) $(TARGET_CFLAGS)"
+endef
+
+define SNOWBALL_HDMISERVICE_INSTALL_STAGING_CMDS
+ $(MAKE) -C $(@D) CC="$(TARGET_CC) $(TARGET_CFLAGS)" DESTDIR=$(STAGING_DIR) install
+endef
+
+define SNOWBALL_HDMISERVICE_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) CC="$(TARGET_CC) $(TARGET_CFLAGS)" DESTDIR=$(TARGET_DIR) install
+endef
+
+define SNOWBALL_HDMISERVICE_UNINSTALL_STAGING_CMDS
+ rm -f $(STAGING_DIR)/usr/lib/hdmiservice.so
+ rm -f $(STAGING_DIR)/usr/bin/hdmistart
+ rm -f $(STAGING_DIR)/usr/include/hdmi_service_api.h
+ rm -f $(STAGING_DIR)/usr/include/hdmi_service_local.h
+endef
+
+define SNOWBALL_HDMISERVICE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/lib/hdmiservice.so
+ rm -f $(TARGET_DIR)/usr/bin/hdmistart
+endef
+
+define SNOWBALL_HDMISERVICE_CLEAN_CMDS
+ $(MAKE) -C $(@D) clean
+endef
+
+
+$(eval $(generic-package))