summaryrefslogtreecommitdiffstats
path: root/package/slang
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-02-25 11:11:27 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-25 15:25:23 +0100
commit34ce7fb6230674cccfc3d329004f3224e95ec09e (patch)
tree3321153e65a8f3eb0463e7c6f4dd5645b8c91a60 /package/slang
parent557982c2624dc138a163f09f683c877e11ccbb34 (diff)
downloadbuildroot-novena-34ce7fb6230674cccfc3d329004f3224e95ec09e.tar.gz
buildroot-novena-34ce7fb6230674cccfc3d329004f3224e95ec09e.zip
slang: fix mips build failure
Closes #3295 Fix MIPS build failure as reported by Thomas Petazzoni. We're forcing CFLAGS and busting -fPIC in the process. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/slang')
-rw-r--r--package/slang/slang.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/slang/slang.mk b/package/slang/slang.mk
index 74c800b0b..0c604d9cd 100644
--- a/package/slang/slang.mk
+++ b/package/slang/slang.mk
@@ -8,8 +8,10 @@ SLANG_SOURCE = slang-$(SLANG_VERSION)-mini.tar.bz2
SLANG_SITE = http://www.uclibc.org/
SLANG_INSTALL_STAGING = YES
+# We need to add -fPIC since we're busting original CFLAGS
+# that have it, see bug #3295
define SLANG_BUILD_CMDS
- $(MAKE1) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+ $(MAKE1) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -fPIC" \
LDFLAGS="$(TARGET_LDFLAGS)" -C $(@D)
endef