summaryrefslogtreecommitdiffstats
path: root/package/sg3_utils
diff options
context:
space:
mode:
authorMarek Belisko <marek.belisko@open-nandra.com>2013-01-18 12:08:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-20 22:38:53 +0100
commitc81a67056e793b5147f39711a34186b2db3f9313 (patch)
tree3f02a99335a01fd7810c23daf1fa8be66a186a97 /package/sg3_utils
parent5a77caa0f944b3b23a492f88ab991c203d5d9acb (diff)
downloadbuildroot-novena-c81a67056e793b5147f39711a34186b2db3f9313.tar.gz
buildroot-novena-c81a67056e793b5147f39711a34186b2db3f9313.zip
sg3_utils: new package
[Peter: rename to sg3-utils, invert package license logic] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sg3_utils')
-rw-r--r--package/sg3_utils/Config.in16
-rw-r--r--package/sg3_utils/sg3_utils.mk40
2 files changed, 56 insertions, 0 deletions
diff --git a/package/sg3_utils/Config.in b/package/sg3_utils/Config.in
new file mode 100644
index 000000000..3262eaef0
--- /dev/null
+++ b/package/sg3_utils/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_SG3_UTILS
+ bool "sg3-utils"
+ depends on BR2_LARGEFILE
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ Low level utilities for devices that use a SCSI command set.
+ This option install only libsgutils2 library not programs.
+
+ http://sg.danny.cz/sg/sg3_utils.html
+
+config BR2_PACKAGE_SG3_UTILS_PROGS
+ bool "install programs"
+ depends on BR2_PACKAGE_SG3_UTILS
+
+comment "sg3-utils requires a toolchain with LARGEFILE and threads support"
+ depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/sg3_utils/sg3_utils.mk b/package/sg3_utils/sg3_utils.mk
new file mode 100644
index 000000000..9015b2aab
--- /dev/null
+++ b/package/sg3_utils/sg3_utils.mk
@@ -0,0 +1,40 @@
+#############################################################
+#
+# sg3_utils
+#
+#############################################################
+
+SG3_UTILS_VERSION = 1.34
+SG3_UTILS_SITE = http://sg.danny.cz/sg/p/
+SG3_UTILS_LICENSE = BSD-3c
+# utils progs are GPLv2+ licenced
+ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),y)
+SG3_UTILS_LICENSE += GPLv2+
+endif
+SG3_UTILS_LICENSE_FILES = COPYING BSD_LICENSE
+
+# install the libsgutils2 library
+SG3_UTILS_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),)
+define SG3_UTILS_REMOVE_PROGS
+ for prog in \
+ dd decode_sense emc_trespass format get_config \
+ get_lba_status ident inq logs luns map26 \
+ map sgm_dd modes opcodes sgp_dd persist prevent \
+ raw rbuf rdac read readcap read_block_limits \
+ read_buffer read_long reassign referrals \
+ requests reset rmsn rtpg safte sanitize \
+ sat_identify sat_phy_event sat_set_features scan \
+ senddiag ses start stpg sync test_rwbuf turs \
+ unmap verify vpd write_buffer write_long \
+ write_same wr_mode ; do \
+ $(RM) $(TARGET_DIR)/usr/bin/sg_$${prog} ; \
+ done
+ $(RM) $(TARGET_DIR)/usr/bin/sginfo
+endef
+
+SG3_UTILS_POST_INSTALL_TARGET_HOOKS += SG3_UTILS_REMOVE_PROGS
+endif
+
+$(eval $(autotools-package))