summaryrefslogtreecommitdiffstats
path: root/package/sed
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-10 22:39:53 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-11 06:01:08 +0200
commitef785f61ad7290508b2640d00403b9a957fcdab1 (patch)
tree622dfa3a37ed0fbfd61d3aad60e5d44ec0a0c531 /package/sed
parent0f5a2ea7765c0d429607998647f8db1197b25a24 (diff)
downloadbuildroot-novena-ef785f61ad7290508b2640d00403b9a957fcdab1.tar.gz
buildroot-novena-ef785f61ad7290508b2640d00403b9a957fcdab1.zip
Do not let packages remove man pages, info pages and documentation
The cleanup of $(TARGET_DIR)/usr/share/man, $(TARGET_DIR)/usr/man, $(TARGET_DIR)/usr/share/info, $(TARGET_DIR)/usr/info, $(TARGET_DIR)/usr/share/doc and $(TARGET_DIR)/usr/doc is already done globally in the main Makefile. Therefore, there's no need to handle that on a per-package basis. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sed')
-rw-r--r--package/sed/sed.mk12
1 files changed, 0 insertions, 12 deletions
diff --git a/package/sed/sed.mk b/package/sed/sed.mk
index 3445deb63..650872569 100644
--- a/package/sed/sed.mk
+++ b/package/sed/sed.mk
@@ -65,12 +65,6 @@ build-sed-host-binary: $(SED_DIR1)/$(SED_BINARY)
rm -rf $(HOST_SED_DIR)/share/locale; \
rm -rf $(HOST_SED_DIR)/usr/share/doc; \
fi
-ifneq ($(BR2_HAVE_INFOPAGES),y)
- rm -rf $(HOST_SED_DIR)/usr/man/info
-endif
-ifneq ($(BR2_HAVE_MANPAGES),y)
- rm -rf $(HOST_SED_DIR)/usr/share/man
-endif
$(HOST_SED_DIR)/$(SED_TARGET_BINARY):
if [ ! -e "$(HOST_SED_DIR)/$(SED_TARGET_BINARY)" ]; then \
@@ -152,12 +146,6 @@ sed-target_binary: $(SED_DIR2)/$(SED_BINARY)
rm -rf $(TARGET_DIR)/share/locale; \
rm -rf $(TARGET_DIR)/usr/share/doc; \
fi
-ifneq ($(BR2_HAVE_INFOPAGES),y)
- rm -rf $(TARGET_DIR)/usr/share/info
-endif
-ifneq ($(BR2_HAVE_MANPAGES),y)
- rm -rf $(TARGET_DIR)/usr/share/man
-endif
sed: sed-target_binary