summaryrefslogtreecommitdiffstats
path: root/package/sed
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-04 21:42:48 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-04 21:45:04 +0200
commit6ce736a58c8973ceba56bc95f11118b7c1351f11 (patch)
treee91a898eaa8d1c1b0dfdb2ff9177aaa763913c7d /package/sed
parent5b72dda69f72e1953dfc7987dd1b418e1afe79a4 (diff)
downloadbuildroot-novena-6ce736a58c8973ceba56bc95f11118b7c1351f11.tar.gz
buildroot-novena-6ce736a58c8973ceba56bc95f11118b7c1351f11.zip
sed: fix compilation with external toolchains
Since CC is already passed in TARGET_CONFIGURE_OPTS at ./configure time, there's no point in overriding it with a wrong value at compilation time. This breaks external toolchain builds since CC=$(TARGET_CC) is wrong because it excludes the mandatory --sysroot option. Fixes bug #525 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sed')
-rw-r--r--package/sed/sed.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/sed/sed.mk b/package/sed/sed.mk
index 9caefed49..07f4b32c6 100644
--- a/package/sed/sed.mk
+++ b/package/sed/sed.mk
@@ -135,7 +135,7 @@ $(SED_DIR2)/.configured: $(SED_DIR2)/.unpacked
touch $@
$(SED_DIR2)/$(SED_BINARY): $(SED_DIR2)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(SED_DIR2)
+ $(MAKE) -C $(SED_DIR2)
# This stuff is needed to work around GNU make deficiencies
sed-target_binary: $(SED_DIR2)/$(SED_BINARY)