summaryrefslogtreecommitdiffstats
path: root/package/sdl_sound
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:52:17 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:52:17 +0200
commite7895986de4ec8819dbb7da4b939d8daec6606a2 (patch)
tree5f68af468e826d22fc54dd6d0979b08feb9b69e3 /package/sdl_sound
parent1860bdae8cdf4f9eb7097fd7e5ed7e9c0c5b6a75 (diff)
downloadbuildroot-novena-e7895986de4ec8819dbb7da4b939d8daec6606a2.tar.gz
buildroot-novena-e7895986de4ec8819dbb7da4b939d8daec6606a2.zip
sdl_sound: cleanup uninstall handling
SDL_SOUND_SUBDIR doesn't exist, so the staging uninstall handling is equivalent to the default one. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sdl_sound')
-rw-r--r--package/sdl_sound/sdl_sound.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/package/sdl_sound/sdl_sound.mk b/package/sdl_sound/sdl_sound.mk
index 9234ab690..bd94a6275 100644
--- a/package/sdl_sound/sdl_sound.mk
+++ b/package/sdl_sound/sdl_sound.mk
@@ -49,14 +49,10 @@ ifneq ($(BR2_PACKAGE_SDL_SOUND_PLAYSOUND),y)
SDL_SOUND_POST_INSTALL_TARGET_HOOKS += SDL_SOUND_REMOVE_PLAYSOUND
endif
-define SDL_SOUND_UNINSTALL_STAGING_CMDS
- $(MAKE) DESTDIR=$(STAGING_DIR) uninstall -C $(@D)/$(SDL_SOUND_SUBDIR)
-endef
-
# target shared libs doesn't get removed by make uninstall if the .la
# files are removed (E.G. if BR2_HAVE_DEVFILES isn't set)
define SDL_SOUND_UNINSTALL_TARGET_CMDS
- $(MAKE) DESTDIR=$(TARGET_DIR) uninstall -C $(@D)/$(SDL_SOUND_SUBDIR)
+ $(MAKE) DESTDIR=$(TARGET_DIR) uninstall -C $(@D)
rm -f $(TARGET_DIR)/usr/lib/libSDL_sound*so*
endef