summaryrefslogtreecommitdiffstats
path: root/package/sdl_sound
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 17:28:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:24:59 +0200
commit3d595a601606534bac4db9dd8ff0e9ca22beeafd (patch)
treec115d0692f27d857aa97d7ffcae0cebeefb41a20 /package/sdl_sound
parent0f5fae2a69b399a81bbef3d8467468f466f2c0ef (diff)
downloadbuildroot-novena-3d595a601606534bac4db9dd8ff0e9ca22beeafd.tar.gz
buildroot-novena-3d595a601606534bac4db9dd8ff0e9ca22beeafd.zip
sdl_sound: convert old-style hooks to new-style hooks
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sdl_sound')
-rw-r--r--package/sdl_sound/sdl_sound.mk23
1 files changed, 13 insertions, 10 deletions
diff --git a/package/sdl_sound/sdl_sound.mk b/package/sdl_sound/sdl_sound.mk
index 3a6b7e742..9234ab690 100644
--- a/package/sdl_sound/sdl_sound.mk
+++ b/package/sdl_sound/sdl_sound.mk
@@ -41,20 +41,23 @@ else
SDL_SOUND_CONF_OPT += --disable-mmx
endif
-$(eval $(call AUTOTARGETS,package,sdl_sound))
+define SDL_SOUND_REMOVE_PLAYSOUND
+ rm $(addprefix $(TARGET_DIR)/usr/bin/,playsound playsound_simple)
+endef
ifneq ($(BR2_PACKAGE_SDL_SOUND_PLAYSOUND),y)
-$(SDL_SOUND_HOOK_POST_INSTALL):
- rm $(addprefix $(TARGET_DIR)/usr/bin/,playsound playsound_simple)
- touch $@
+SDL_SOUND_POST_INSTALL_TARGET_HOOKS += SDL_SOUND_REMOVE_PLAYSOUND
endif
-# target shared libs doesn't get removed by make uninstall if the .la files
-# are removed (E.G. if BR2_HAVE_DEVFILES isn't set)
-$(SDL_SOUND_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define SDL_SOUND_UNINSTALL_STAGING_CMDS
$(MAKE) DESTDIR=$(STAGING_DIR) uninstall -C $(@D)/$(SDL_SOUND_SUBDIR)
- rm -f $(@D)/.stamp_staging_installed
+endef
+
+# target shared libs doesn't get removed by make uninstall if the .la
+# files are removed (E.G. if BR2_HAVE_DEVFILES isn't set)
+define SDL_SOUND_UNINSTALL_TARGET_CMDS
$(MAKE) DESTDIR=$(TARGET_DIR) uninstall -C $(@D)/$(SDL_SOUND_SUBDIR)
rm -f $(TARGET_DIR)/usr/lib/libSDL_sound*so*
- rm -f $(SDL_SOUND_TARGET_INSTALL_TARGET) $(SDL_SOUND_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,sdl_sound))