summaryrefslogtreecommitdiffstats
path: root/package/sdl_image
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2009-11-23 23:05:23 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-11-23 23:05:23 +0100
commit883f066797ae0e7a017fac8e275f6e58659db760 (patch)
treede10c1085278f7e08fe9dc84a38289ad164d59de /package/sdl_image
parent9627e21153693f296f41c0339e14d6ed18445d7e (diff)
downloadbuildroot-novena-883f066797ae0e7a017fac8e275f6e58659db760.tar.gz
buildroot-novena-883f066797ae0e7a017fac8e275f6e58659db760.zip
SDL_image: fix runtime libjpeg failure
By default SDL_image loads libjpeg at runtime on-demand. The find_lib routine in the configure script of SDL_image searches the /usr/lib directory of the host machine to find the file name of the jpeg library. When the host on which Buildroot is being built contains newer version of libjpeg (e.g. libjpeg7), the configure script incorrectly uses its file name. The result is a runtime failure to load libjpeg. Fix this by disabling runtime load of libjpeg. [Peter: disable for png+tiff as well] Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sdl_image')
-rw-r--r--package/sdl_image/sdl_image.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/sdl_image/sdl_image.mk b/package/sdl_image/sdl_image.mk
index 127a2922b..772bb8606 100644
--- a/package/sdl_image/sdl_image.mk
+++ b/package/sdl_image/sdl_image.mk
@@ -14,6 +14,9 @@ SDL_IMAGE_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
--with-sdl-exec-prefix=$(STAGING_DIR)/usr \
--disable-sdltest \
--disable-static \
+ --disable-jpg-shared \
+ --disable-png-shared \
+ --disable-tif-shared \
--enable-bmp=$(if $(BR2_PACKAGE_SDL_IMAGE_BMP),yes,no) \
--enable-gif=$(if $(BR2_PACKAGE_SDL_IMAGE_GIF),yes,no) \
--enable-jpg=$(if $(BR2_PACKAGE_SDL_IMAGE_JPEG),yes,no) \