summaryrefslogtreecommitdiffstats
path: root/package/sdl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-17 22:36:19 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-18 09:46:31 +0100
commit95da46dfd6536a13768ef029a97c14de6805a947 (patch)
tree99827ed19e731d6e391e4c9e229aa2f57d6bf053 /package/sdl
parente7d8d855f0ab28d6cd608b7204a9e13a18b15092 (diff)
downloadbuildroot-novena-95da46dfd6536a13768ef029a97c14de6805a947.tar.gz
buildroot-novena-95da46dfd6536a13768ef029a97c14de6805a947.zip
sdl: use <pkg>_CONFIG_SCRIPTS for sdl-config
Use the <pkg>_CONFIG_SCRIPTS mechanism to handle the sdl-config script, so that it properly gets removed from the target. However, we can't completely remove the manual fixup, because it also takes care of removing the -Wl,-rpath option, which the general <pkg>_CONFIG_SCRIPTS doesn't do. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/sdl')
-rw-r--r--package/sdl/sdl.mk9
1 files changed, 3 insertions, 6 deletions
diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
index 4786dc5d7..fb47c4d19 100644
--- a/package/sdl/sdl.mk
+++ b/package/sdl/sdl.mk
@@ -57,13 +57,10 @@ SDL_CONF_OPT += --enable-pulseaudio=no \
--disable-nasm \
--disable-video-ps3
-# Fixup prefix= and exec_prefix= in sdl-config, and remove the
-# -Wl,-rpath option.
+SDL_CONFIG_SCRIPTS = sdl-config
+
+# Remove the -Wl,-rpath option.
define SDL_FIXUP_SDL_CONFIG
- $(SED) 's%prefix=/usr%prefix=$(STAGING_DIR)/usr%' \
- $(STAGING_DIR)/usr/bin/sdl-config
- $(SED) 's%exec_prefix=/usr%exec_prefix=$(STAGING_DIR)/usr%' \
- $(STAGING_DIR)/usr/bin/sdl-config
$(SED) 's%-Wl,-rpath,\$${libdir}%%' \
$(STAGING_DIR)/usr/bin/sdl-config
endef