summaryrefslogtreecommitdiffstats
path: root/package/sdl
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/sdl
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/sdl')
-rw-r--r--package/sdl/sdl.mk29
1 files changed, 20 insertions, 9 deletions
diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk
index 66ca6bbc1..e25d60acb 100644
--- a/package/sdl/sdl.mk
+++ b/package/sdl/sdl.mk
@@ -23,14 +23,25 @@ $(SDL_DIR)/.configured: $(SDL_DIR)/.unpacked
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=$(STAGING_DIR)/usr \
- --disable-arts \
- --disable-esd \
- --disable-nasm \
- --disable-video-x11 );
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-arts \
+ --disable-esd \
+ --disable-nasm \
+ --disable-video-x11 );
touch $(SDL_DIR)/.configured
$(SDL_DIR)/.compiled: $(SDL_DIR)/.configured
@@ -38,7 +49,7 @@ $(SDL_DIR)/.compiled: $(SDL_DIR)/.configured
touch $(SDL_DIR)/.compiled
$(STAGING_DIR)/usr/lib/libSDL.so: $(SDL_DIR)/.compiled
- $(MAKE) -C $(SDL_DIR) install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SDL_DIR) install;
touch -c $(STAGING_DIR)/usr/lib/libSDL.so
$(TARGET_DIR)/usr/lib/libSDL.so: $(STAGING_DIR)/usr/lib/libSDL.so